ssl

Problems with the Linux version of XAMPP, questions, comments, and anything related.

ssl

Postby sitespider » 10. December 2003 14:03

Hi,

I am trying to configure ssl on my server and i have a couple of questions:
1) how do i edit the ssl certificate
2) is it possible to make one of the folders in my site only accessable through ssl

thanks

Phil
sitespider
 
Posts: 6
Joined: 10. December 2003 13:55

Postby Oswald » 10. December 2003 17:58

Hi Phil!

To create a self-signe certificate simple do the following three steps:

Step 1

Create a new private key for your server and call
/opt/lampp/bin/openssl genrsa 1024 > /opt/lampp/etc/ssl.key/server.key


Step 2

Sign your key by calling

/opt/lampp/bin/openssl req -new -x509 -key /opt/lampp/etc/ssl.key/server.key -out /opt/lampp/etc/ssl.crt/server.crt

Now you have to answer some questions about you and your organisation. The question about "Common Name (eg, YOUR name)" you've to answer with the Internet address of you webserver. For example "www.apachefriends.org". Without http://.

Step 3

Make the Apache know the new certificate:

/opt/lampp/lampp reloadapache

And you access your web sever via https. You should now get your new certifcate.

To your second question: Use for you SSL virtual host a different document root and simply put the files you only want to get by SSL on into this directory.

Good luck and greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby sitespider » 10. December 2003 23:15

thanks that works great
sitespider
 
Posts: 6
Joined: 10. December 2003 13:55

Once tried to install ssl everthing went crazy!

Postby kevinm2 » 02. September 2004 01:03

Everything was running fine, till I tried to have gerenate a ssl connection.

now, in the error_log I am getting "[notice] caught SIGTERM, shutting down".

when I type in "http://www.domain.com" everthing is fine. But with "https://www.domain.com" it hangs.

In the httpd.conf, all I have added is the follwoing:
### Section 1
Listen 80
Listen 443

### Section 2
ServerAdmin info@domain.com
ServerName www.domain.com:80

DocumentRoot "/opt/lampp/htdocs/domain"

<Directory "/opt/lampp/htdocs/domain">
.
.
</Directory>

DirectoryIndex index.html index.htm index.php

In the ssl.conf, all I have added is the follwoing:

## SSL Virtual Host Content

<VirtualHost _Default_:443>
DocumentRoot "/opt/lampp/htdocs/domain"
ServerName www.domain.com:443

and the route to the ssl.key and ssl.crt that I generated myself.

Furthermore, when I go to the server via a URL "http://www.domain.com/index.php" I get the actual php code and not the htm format.

What am I doing wrong :?:
kevinm2
 
Posts: 8
Joined: 02. September 2004 00:34


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests