Installing PHPUnit... need to update PEAR Installer

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Installing PHPUnit... need to update PEAR Installer

Postby Ms_Sutani » 09. June 2009 22:00

I'm trying to install PHPUnit with XAMPP but i get an error message saying I need to upgrade PEAR Installer from 1.7.2. to 1.8.1.

How do you update PEAR Installer on XAMPP?
User avatar
Ms_Sutani
 
Posts: 7
Joined: 18. May 2009 12:24

Re: Installing PHPUnit... need to update PEAR Installer

Postby Wiedmann » 09. June 2009 22:04

How do you update PEAR

Like updating every other PEAR package.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Installing PHPUnit... need to update PEAR Installer

Postby Ms_Sutani » 24. June 2009 11:58

well my problem is that if i try to install or update anything in pear i get an error message about memory being exhausted. This cannot be the case because I have 4 gigs of ram. Here is the error message:

Fatal error: Allowed memory size of 8388608 bytes exhausted

I have other machines where I have manually installed linux, apache, mysql, and php (no xampp) and I can upgrade pear just fine there, so i know it's not a syntax issue.

any ideas?
User avatar
Ms_Sutani
 
Posts: 7
Joined: 18. May 2009 12:24

Re: Installing PHPUnit... need to update PEAR Installer

Postby Wiedmann » 24. June 2009 12:00

my problem is that if i try to install or update anything in pear i get an error message about memory being exhausted.

http://de.php.net/manual/en/ini.core.php#ini.memory-limit
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests