Couldn't start MySQL!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Re: Couldn't start MySQL!

Postby shamun » 03. January 2010 11:52

[SOLVED] - Fedora 8, 12, CentOS 5.0, Red Hat, estimated time [ 5 minutes ]

Step 1: [ you dont need if you are trying to debug your existing problem, this is a fresh startup for XAMPP, i must have to run it, in that case ]
* if you have problem running first mysql.
1. yum remove mysql\*


Any manual (rm -fr lampp, or find / -name "mysql*" ), and simply remove them to trash first (don't do full delete always, make sure)

Step 2: [Careful]

1. LAMPP is a solid working tool, but you will start those problem if you choosed
GUI extract ( like window > select zip file > unzip !! no :?: )
2. Use the command mentioned in XAMPP site after you download:
$ tar xvfz xampp-linux-1.7.3.tar.gz -C /opt

* It will not miss any file inside the compressed tar.gz and put all provided files by XAMPP (developers) to /opt (so you are safely landed by XAMPP, without crash landing)

Step 3:
1. Are you root ? or sudo ? what ever use
$ su
$ password: myrootpassword_press_enter
[root@shamun opt]# chown /opt/lampp/var/mysql
* please note its not going to solve, you can give a try, for me didnt worked by chaning permissions/ chroot/ chown (but you can try)

Step 4:
1. $/opt/lampp/lampp start
2. if anything failed repeat step 1 till 4, post here also
Posts: 3
Joined: 03. January 2010 11:27

Re: Couldn't start MySQL!

Postby gustavo » 09. January 2010 03:43

I,ve deleted the solution I proposed:
"Change the permissions into /opt/lampp/var/mysql to 'nobody'"

geebers is true. It's very unsafe. Thanks, geebers.
Last edited by gustavo on 09. January 2010 14:03, edited 1 time in total.
Posts: 1
Joined: 09. January 2010 03:33

Re: Couldn't start MySQL!

Postby geebers » 09. January 2010 04:15

Don't do what gustavo told you to. If you did, then anyone who can even view a page would have permissions to write to your database! BAD GUSTAVO!!!

After you installed xampp, did your run (as root), /opt/lampp/lampp security
then follow directions?

It's mandatory.
Posts: 7
Joined: 08. January 2010 16:45

Re: Couldn't start MySQL!

Postby dhani48 » 15. May 2010 15:36

lukai wrote:Hi, I'm using a xubuntu 8.10 Usb version.

After installing Xampp in /opt I start it and ... everything start correctly but ... Xampp: Coulden't start MySQL!
If I try /opt/lampp/lampp status I see:
Apache is running.
MySQL is not running.
ProFTPD is running.

Any suggestion?

P.S. I am a new linux user (2 week)

you change user to root
and with commad tar:
Code: Select all
tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt

after on the folder

Code: Select all
./lampp start
Posts: 1
Joined: 15. May 2010 15:18

That fixed it for me and here's why...

Postby djdevon3 » 20. May 2010 00:36

I had the same problem and I'll detail how I got it and how I fixed it.
I downloaded the xampp tar into my tmp folder as usual. I double clicked on the file and it started installing. After getting everything setup I ran into the "MySQL couldn't start" error. It is indeed because I installed it by double clicking on the file instead of using console.

The reason why everyone is getting this error is because you have not installed XAMPP as root. Double clicking the tar will not install as root. Using console and forgetting su or sudo will also produce the same error (it shouldn't even let you install it that way tho). You MUST install as root. ;)

SUDO is the key. Without it you can't install MySQL properly (as it requires root) and it will fail when you try to use it.

Code: Select all
sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt

Everything was good after that.
Posts: 2
Joined: 20. May 2010 00:25

Re: Couldn't start MySQL!

Postby xadhix » 17. June 2010 04:51

Thanks djdevon :) It worked for me :)
Posts: 2
Joined: 17. June 2010 04:46

Re: Couldn't start MySQL!

Postby carlos007 » 28. October 2010 21:57

I had that problem an I SOLVED this way:

I had this error:

Starting XAMPP for Linux 1.7.1...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

I coudn't start mysql cause a mysql instanse was already running.

In the terminal i did:
apt-cache show mysql-server | grep Version
and the terminal show me the mysql version
so I did:
sudo mysql
and I got the prompt: mysql>

That was I installed bacula backup which installed mysql

So I used Synaptic Package Manager to uninstall bacula and mysql (severals packages of bacula and mysql)

Thats all.
Posts: 1
Joined: 28. October 2010 21:28

Re: Couldn't start MySQL!

Postby henryubuntu » 19. December 2010 03:19

THANKS a lot, I was going to format the system just for that tiny mistake.

Again, thanks.
Posts: 1
Joined: 19. December 2010 03:17


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests