Connect to mysql

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Re: Connect to mysql

Postby Wiedmann » 14. March 2009 22:57

Code: Select all
090314 20:36:30 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

This can not happens with a fresh XAMPP installation.

We must know more about your installation:
- it's a fresh installation?
- it's a upgrade installation?

- you have changed anything in the installation (config files / permissions)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Connect to mysql

Postby edykory » 01. May 2009 21:03

Wiedmann wrote:
Code: Select all
090314 20:36:30 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

This can not happens with a fresh XAMPP installation.

We must know more about your installation:
- it's a fresh installation?
- it's a upgrade installation?

- you have changed anything in the installation (config files / permissions)?


Actually I got into the same problem.
The pattern was the following:

I untarred the xampp-linux-1.7.1 to my usual development folder. Then I noticed that there are some hard coded links to /opt, so I moved the whole lampp folder to /opt. At this moment I started the lampp stack with
Code: Select all
 sudo ./lampp start
which, in response, game me something similar to:
090305 11:40:43 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
/opt/lampp/sbin/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13)
090305 11:40:44 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090305 11:40:45 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /opt/lampp/var/mysql/ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.
090305 11:40:45 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/tirengarfio-laptop.pid ended


The problem I think was from the fact that the owner of the lampp folder was my user, not the root.
After removing the lampp folder and untarring again directly in /opt with sudo tar xvf xamp...... everything went smoothly.

Eduard
edykory
 
Posts: 1
Joined: 01. May 2009 20:57

Previous

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests