VirtualHost not working..

Problems with the Linux version of XAMPP, questions, comments, and anything related.

VirtualHost not working..

Postby Goce » 02. February 2009 22:01

I don't know if I even have the right idea here, so please bear with me..

I have a domain.com forwarded to my IP address..
then in my httpd.conf file I have;

NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot /opt/lampp/htdocs/vrgs
ServerName domain.com
ServerAlias www.domain.com
</virtualHost>

But all domain.com names are my domain name....

Here it is, When no VirtualHost it goes to htdocs/index.html.... And when the VirtualHost is there it goes to a blank white page... I don't understand at all what's going on with this XAMPP server bundle.. Can anyone help me with this please? TY!

I hope I provided enough information, however if something else is needed I will obviously post it.. Thanx again!
Goce
 
Posts: 8
Joined: 31. January 2009 00:10

Re: VirtualHost not working..

Postby dmphotography » 04. February 2009 10:25

This is not the correct way to use VirtualHost. You do not add VirtualHosts to your httpd.conf file.

I just finished creating a tutorial on how to configure VirtualHosts on Linux and you can take a look at it and see if that helps. It will better explain VirtualHosts as well so you have a better understanding of how they work.

http://www.myownserver.info/index.php/additional-configurations-and-settings-linux/47-linuxmultiplewebsiteconfiguration.html
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7

Re: VirtualHost not working..

Postby Goce » 04. February 2009 14:03

ty. I knew that I did n't have a complete understanding. Thanks again for the link!
Goce
 
Posts: 8
Joined: 31. January 2009 00:10


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests