CHANGE DOCUMENT ROOT wont work

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Postby Guest » 18. November 2003 12:32

Tue Nov 18 10:48:20 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 18 10:48:20 2003] [notice] Digest: done
[Tue Nov 18 10:48:21 2003] [notice] Apache configured -- resuming normal operations
[Tue Nov 18 10:58:49 2003] [notice] caught SIGTERM, shutting down
[Tue Nov 18 10:59:00 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 18 10:59:05 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 18 10:59:05 2003] [notice] Digest: done
[Tue Nov 18 10:59:06 2003] [notice] Apache configured -- resuming normal operations
[Tue Nov 18 12:18:04 2003] [notice] caught SIGTERM, shutting down
[Tue Nov 18 12:22:16 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 18 12:22:24 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 18 12:22:24 2003] [notice] Digest: done
[Tue Nov 18 12:22:25 2003] [notice] Apache configured -- resuming normal operations
[Tue Nov 18 12:22:38 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:22:40 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:22:47 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:22:56 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:23:00 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:24:50 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
[Tue Nov 18 12:34:01 2003] [error] [client 192.168.0.2] File does not exist: /opt/lampp/htdocs
Guest
 

Postby Oswald » 18. November 2003 12:34

Your document root is still set to /opt/lampp/htdocs.

Did you change /opt/lampp/etc/httpd.conf?
Did you restart Apache?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 18. November 2003 12:35

yes..
Guest
 

Postby Guest » 18. November 2003 12:36

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/home/Bb0y/www"

#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/home/Bb0y/www">

restarted it too often for words :P
Guest
 

Postby Guest » 18. November 2003 12:42

[t01l33t@e198200 lampp]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4...
LAMPP: Starting Apache with SSL...
Warning: DocumentRoot [/opt/lampp/htdocs] does not exist
Guest
 

Postby Oswald » 18. November 2003 14:31

Please call egrep /opt/lampp/htdocs /opt/lampp/etc/httpd.conf

What shows up to the screen?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 18. November 2003 17:03

diesen telefonieren nummer ist nicht in gebruche :?: :wink:


the first says uhm totally nothing i have to press ctrl-c
the second also? :shock:
nothing happens..
Guest
 

Postby Guest » 18. November 2003 17:04

is that a intense program cuz my server aint that fast (133mhz,48mb)
Guest
 

Postby Oswald » 18. November 2003 17:06

No no no. I should take only a split of a second.

Did you type exact the command. I repeat it with another font:

Code: Select all
egrep /opt/lampp/htdocs /opt/lampp/etc/httpd.conf
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 18. November 2003 17:29

[t01l33t@e198200 lampp]# egrep /opt/lampp/htdocs /opt/lampp/etc/httpd.conf
[t01l33t@e198200 lampp]#
Guest
 

Postby Oswald » 18. November 2003 17:38

I forgot! Take a look into /opt/lampp/etc/ssl.conf

You will find a second DocumentRoot. It's for the HTTPS Apache. Change this line too and the warning should disappear.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 18. November 2003 17:54

it fixed it tks :lol: ... now i have permission issues lol..
and at status page everything is deactivated :shock:
Guest
 

Postby noobie » 19. November 2003 06:09

Hi all maybi shud have made another topic but i didnt.

Welcome to XAMPP for Linux
Warning: main(): open_basedir restriction in effect. File(./.version) is not within the allowed path(s): (/home/Bb0y/www) in /home/Bb0y/www/xampp/start.php on line 10

Warning: main(.version): failed to open stream: Bewerking niet toegestaan in /home/Bb0y/www/xampp/start.php on line 10

Warning: main(): Failed opening '.version' for inclusion (include_path='.:/opt/lampp/lib/php') in /home/Bb0y/www/xampp/start.php on line 10
!
This .version file is the only file in my htdocs (renamed to www) folder which has not the nobody owner. weird enough, if im logged in as root and i do:
chown -v .version nobody.nobody
it says invalid group
when i rename the file to version
and do
chown -v version nobody.nobody
it says
invalid user

and another thing, in my Xampp at the status page it says everything is DEACTIVATED, but it is not. How can i fix this :S Because its simply that he doesnt looks in the right folder to check if these files are activated..

Greetings and keep up the good work :o
noobie
 

Postby Guest » 19. November 2003 06:23

ok i re-commented the open basedir in php.ini now my error msgs are all gone, but still on my status page everything is deactivated :P help svp :-)
Guest
 

Postby Oswald » 19. November 2003 10:04

Do the demo pages (like CD collection etc) work?

Please read the comment at the status page: "Some changes to the configuration sometimes may cause false negative status reports." The status page is not absolute confidently.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

PreviousNext

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests