Apache doesnt start when i start lampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache doesnt start when i start lampp

Postby janindu » 12. January 2009 05:56

When i start lampp from inside or when i restart lampp the following appears :
[root@nwu182 lampp]# ./lampp start
Starting XAMPP for Linux 1.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: XAMPP-MySQL is already running.
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

or when i restart the lampp:
[root@nwu182 lampp]# ./lampp restart
Stopping XAMPP for Linux 1.7...
XAMPP: XAMPP-Apache is not running.
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

i cannot figure this out and im fairly new to linux too.....!!!!









:(
janindu
 
Posts: 5
Joined: 12. January 2009 05:44

Re: Apache doesnt start when i start lampp

Postby Wiedmann » 12. January 2009 06:25

There is an "apachestart.log" somewhere...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby janindu » 12. January 2009 07:01

i found the apachestart.log it says syntax error on line 54 of opt/ lampp/etc/http.conf : cannot load f opt/ lampp/etc/htdocs/joomla/ modules/mod_authin _file. so into server nw wht to do......?????? :|
Last edited by janindu on 12. January 2009 07:09, edited 1 time in total.
janindu
 
Posts: 5
Joined: 12. January 2009 05:44

Re: Apache doesnt start when i start lampp

Postby Wiedmann » 12. January 2009 07:03

nw wht to do

Read it... (or post it).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache doesnt start when i start lampp

Postby janindu » 12. January 2009 07:10

apachestart.log it says syntax error on line 54 of opt/ lampp/etc/http.conf : cannot load f opt/ lampp/etc/htdocs/joomla/ modules/mod_authin _file. so into server
janindu
 
Posts: 5
Joined: 12. January 2009 05:44

Re: Apache doesnt start when i start lampp

Postby janindu » 12. January 2009 07:21

Guys need some help ASAP......PLEASE>>>>>>.......!!!!!!!!! :(
janindu
 
Posts: 5
Joined: 12. January 2009 05:44

Re: Apache doesnt start when i start lampp

Postby Wiedmann » 12. January 2009 07:33

f opt/ lampp/etc/htdocs/joomla/ modules/mod_authin _file. so

If 've never seen this module. And modules from XAMPP Apache are never in this path. So just remove this line.

Im fairly new to linux too

Maybe a good reason to not change anything in the Apache config file... Have you changed more?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache doesnt start when i start lampp

Postby janindu » 12. January 2009 09:23

Nope i connected to apache the issue was in the httpd file in the lampp directory
i had set the wrong root server path.....????? :oops: now im trying to install joomla have ever installed joomla on linux :?: im stuck on backing up the data bases.....!!!
janindu
 
Posts: 5
Joined: 12. January 2009 05:44


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests