xampp phpsuexec

Problems with the Linux version of XAMPP, questions, comments, and anything related.

xampp phpsuexec

Postby loveunit » 14. December 2008 15:08

Hi -

I've been using xampp about a year, firstly on windows, now I run it from Ubuntu, my server is linux.

I was having lots of problems with permissions on my server due to my php code generating, editing and deleting file - the file owner / group was always nobody - as this is how php was running, so my host suggested reinstalling PHP in PHPsuexec as an apache module, which has fixed all the issues.

however, my local machine using xampp still has these permission issues - I wanted to know if it is possible to change some settings to stop PHP running under user nobody when using xampp?

thanks in advance.
Posts: 1
Joined: 14. December 2008 13:42

Re: xampp phpsuexec

Postby glitzi85 » 14. December 2008 16:12

PHP is running under the same user as Apache (in default XAMPP configuration). Open the file /opt/lampp/etc/httpd.conf and change

Code: Select all
User nobody
Group nogroup

to whatever you want. Then stop apache, modify rights on all necessary folders in lampp and start Apache again.

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests