lampp looking at wrong mysql, gives wrong status

Problems with the Linux version of XAMPP, questions, comments, and anything related.

lampp looking at wrong mysql, gives wrong status

Postby korg » 19. November 2008 01:41

my lampp install works fine, but ive noticed an odd thing recently.

when i run lampp start (as root), everything starts, including mysql, and i can see mysql running as a process.

when i run lampp stop, everything stops, including mysql, and the process disappears.

also, i have phpbb and phpmyadmin running on the instance and both work fine, so i know the database is working

however, recently, when i run lampp status, lampp thinks that mysql is not running, and so utilities like lampp security and the config webpage dont work quite right. before i didnt have this problem. i dont know why it has occurred now.

i checked the system and there is another copy of mysql in /usr/bin but looks like that hasnt been set up properly, and since /usr/bin is in my path, running mysql status from the command line will try to start up this non working version of mysql first. i dont know if this affects what lampp is checking when i run a status check though.

if anyone has any info on how to get lampp to check the correct mysql process, id appreciate any help. thanks.

i dont want to modify the path or delete the other mysql install if possible since this server is used by others as well and i dont want to mess around with things too much.
Posts: 5
Joined: 22. April 2008 19:19

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests