Tomcat Install : Problem with /etc/host

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Tomcat Install : Problem with /etc/host

Postby bino » 11. November 2008 05:39

Dear All

First , My basic XAMPP install is running OK.

I Install Tomcat ... and test it with calling the host at port 8080 ... and it's good.

Now .. time to take care about connector ...

I download and extract the XAMPP devel ... to /opt.

I download : tomcat-connectors-current-src.tar.gz from tomcat website
extract it to my development directory ,
cd to "native" directory ... and do --> ./configure ./configure --with-apxs=/opt/lampp/bin/apxs
looks ok ..

make and make install,
ended with
Code: Select all
chmod 755 /opt/lampp/modules/mod_jk.so

Please be sure to arrange /opt/lampp/conf/httpd.conf...


Here is what I added to my httpd.conf
Code: Select all
LoadModule    jk_module  /opt/lampp/modules/mod_jk.so
JkWorkersFile /opt/lampp/etc/workers.properties
JkShmFile     /opt/lampp/var/log/httpd/mod_jk.shm
JkLogFile     /opt/lampp/var/log/httpd/mod_jk.log
JkLogLevel    info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
# Send everything for context /examples to worker named worker1 (ajp13)
JkMount  /examples/* worker1


And here is /opt/lampp/etc/workers.properties
Code: Select all
worker.list=wlb,jkstatus

worker.ajp13w.type=ajp13
worker.ajp13w.host=ubuntu-xx
worker.ajp13w.port=8009

worker.wlb.type=lb
worker.wlb.balance_workers=ajp13w

worker.jkstatus.type=status



Time to test this connector installation
I stop TOMCAT
I Stop XAMPP

/opt/lampp/lampp start
It Failed starting Apache
Code: Select all
Starting XAMPP for Linux 1.6.8a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Your /etc/hosts is not okay. I will fix it.
XAMPP: See also http://www.apachefriends.org/faq-lampp-en.html#failed


Here is my /etc/hosts content :
Code: Select all
root@ubuntu-xx:/sda2/ngoprek/tomcat-connectors-1.2.27-src/native# more /etc/hosts
127.0.0.1 localhost
127.0.0.1 ubuntu-xx


Kindly please give me any enlightment.

Sincerely
-bino-
bino
 
Posts: 1
Joined: 11. November 2008 05:07

Postby Nobbie » 11. November 2008 10:28

I dont think that the error message of Xampp is right.

In order to find out what really(!) is going wrong, dont use lampp-Script to start apache, but start it native from command-line: change directory to /opt/lampp/bin and type "sudo ./httpd". This starts Apache directly and you will see all errors, which cause Apache (httpd) to fail.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests