mod rewrite not working on linux, working on windows

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mod rewrite not working on linux, working on windows

Postby magicPee » 05. November 2008 19:42

hello friends,

last week i switched from windows to linux on my main pc
installed lampp
but now i have this problem : for my sites i use simple mod_rewrite

Code: Select all
# Ignore real directories.
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^([-a-z0-9]+)/?$  index.php?toon=$1 [NC,QSA,L]


basic rewrite script
but this isn't working !

i do have a 2nd pc with windows, and there its working fine

my lampp is basic, i just installed apachefriends lampp, and didnt change anything in the httpd.conf

any help ?

P.
magicPee
 
Posts: 1
Joined: 05. November 2008 16:19

Postby glitzi85 » 06. November 2008 19:42

Look in httpd.conf for this Line:

Code: Select all
LoadModule rewrite_module modules/mod_rewrite.so


If there is an # before, remove it and restart Apache.

Additional you can change your .htaccess to this one:

Code: Select all
# Ignore real directories.
foobar
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^([-a-z0-9]+)/?$  index.php?toon=$1 [NC,QSA,L]


and then try again. As foobar is not a valid option you should get an Error Code in your Browser, otherwise the .htaccess file is not parsed.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests