Problem Vhosts.conf Apache SSL

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem Vhosts.conf Apache SSL

Postby Herby » 08. November 2003 16:53

Hello..
I have a clean installed Xampp
When i use in httpd.conf "included /opt/lampp/etc/Vhosts.conf" and ad any domain then SSL is not work anymore on the main server.
Before i add any domain works SSL 100%

Example:

My own domain: http://www.blabla.nl and https://www.blabla.nl works
After i add virtual domain: www.otherdomain.tld then http://www.blabla.nl not work anymore.

What i do wrong???????????
Herby
 

Postby Oswald » 08. November 2003 17:30

Hi Herby!

What you're saying is a little bit confuse.

Firstly you said SSL isn't working any more if you add another virtual host. (1)

But in your example it's not an SSL host stopped working it's a normal virtual host. (http://.. not working anymore) (2)

What is your problem exacly? 1 or 2?

Another question: Do you define any SSL virtual hosts in you Vhosts.conf?

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Herby » 08. November 2003 19:09

Hello Oswald.
Ok i try to explain it..
My serverdomain is http://www.blabla.nl
This domain works also on https://www.blabla.nl (SSL = On)
Everything is working but when i add a other domain (VirtualHost) then domain http://www.blabla.nl dont work anymore.
I have included Vhosts.conf

I do the same in Redhat and Mandrake without Xampp and there i have no problems on this way.

Greatings Herby
Herby
 

Postby Oswald » 08. November 2003 19:15

Dear Herby!

Okay, I understand. So it has nothing to do with SSL. Right?

http://www.blabla.nl works. And after including vhosts.conf. It doesn't work anymore. Right?

Is http://www.blabla.nl defined as virtual host? Or is it just the "main server"?

Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Herby » 09. November 2003 10:37

Kai Seidler wrote:Dear Herby!


Is http://www.blabla.nl defined as virtual host? Or is it just the "main server"?

Oswald

Hello Oswald,
http://www.blabla.nl is the mainserver and not virtualhost.
Herby
 

Postby Oswald » 09. November 2003 13:13

Hello Herby!

Please define www.blabla.nl as virtual host. That's all. Set your main server to something you didn't need. So you get www.blabla.nl working and your broken main server doesn't care any more.

Yes. It's not a perfect solution but it's working. ;)

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Herby » 09. November 2003 13:42

Kai Seidler wrote:Hello Herby!

Please define www.blabla.nl as virtual host. That's all. Set your main server to something you didn't need. So you get www.blabla.nl working and your broken main server doesn't care any more.

Yes. It's not a perfect solution but it's working. ;)

Greetings
Oswald

Kai Seidler wrote:Hello Herby!

Please define www.blabla.nl as virtual host. That's all. Set your main server to something you didn't need. So you get www.blabla.nl working and your broken main server doesn't care any more.

Yes. It's not a perfect solution but it's working. ;)

Greetings
Oswald

Hi Oswald,
i know it's not perfect on this way, but everything is working now.
Thanks for the good work :)
Best regards,
Herbert
Herby
 
Posts: 2
Joined: 09. November 2003 10:40
Location: Doetinchem Holland


Return to XAMPP for Linux

Who is online

Users browsing this forum: izik-kun and 6 guests