XAMPP redirecting page to localhost of accessing page on LAN

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP redirecting page to localhost of accessing page on LAN

Postby deeprao » 03. October 2008 13:57

Hi

I am using XAMPP for Linux and installed Wordpress to work on it.
I am using the htdocs folder where i downloaded my installation for Wordpress.
Now everytime I run my page, it always gets redirected to localhost.
Meaning, if i say http://<machine_name>/fusion on a machine that has access to the server (meaning on LAN), it gets redirected to http://localhost/fusion.
As localhost/fusion is not available on the current machine, i get a 404 error.

Please suggest what configuration needs to be changed

Thank
Deepika
deeprao
 
Posts: 3
Joined: 03. October 2008 13:50

Postby Wiedmann » 03. October 2008 18:02

Please suggest what configuration needs to be changed

That's a setting (server name) in Wordpress.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deeprao » 05. October 2008 07:02

Thanks for the reply.
Any idea where that setting could be found.. i tried but did not get that!
deeprao
 
Posts: 3
Joined: 03. October 2008 13:50

Postby glitzi85 » 06. October 2008 10:38

Hi,

log in to Wordpress as admin, go to Settings and check the WordPress adress and Blog adress Settings.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby deeprao » 07. October 2008 07:38

hi

thanks for the reply.

i tried that but its also getting reset to localhost
asking this in the wordpress forum, they said its an apache issue!

please help :(
deeprao
 
Posts: 3
Joined: 03. October 2008 13:50

Postby glitzi85 » 07. October 2008 12:39

It is definitely the problem of Wordpress. I get the same problem here, when installing WP local.

Open phpmyadmin and select the database used by wordpress. Then open the table "options" (should be wp_options - depending on what you provided as table prefix during installation).

Look for the Row with the Option Names "siteurl" and "home" (should be id 1 and 39). Change the value of option_value from this two rows by removing the absolute URL. For example:

Before: http://localhost/wordpress
After: /wordpress

Now your Wordpress should work with every Hostname.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests