clean urls and local mail server for drupal

Problems with the Linux version of XAMPP, questions, comments, and anything related.

clean urls and local mail server for drupal

Postby maiadrupal » 23. September 2008 05:10

hello,

I'm a newbie happy user of xampp for linux

I'm running an evaluation drupal site, and all works fine (except some parameters for security, but let's talk about that next time)

1 - my big trouble in this moment is enabling clean urls, which I really need

I tried a lot of things, following guides, howtos... I fixed the httpd.conf and so on... nothing, in the drupal configuration it continues to say that the server does not support clean urls

could please anyone suggest a safe solution?

2 - the second important thing is to install and use a local mail server to simulate a real site behavior: this time I read a lot of stuff, but I didn't try anything, because nothing refers specifically to xampp for linux...

have you already fixed this issue? could you help me?

--

thank you all, I hope in the future I could be of some help (feel free to write a private message, please)

maia
maiadrupal
 
Posts: 4
Joined: 23. September 2008 04:56

Postby Wiedmann » 23. September 2008 06:48

I fixed the httpd.conf

What exactly?

(XAMPP/Apache sepecific: Verify that the mod_rewrite module is enabled.)

2 - the second important thing is to install and use a local mail server

A mailserver is part of your Linux distribution. So, read the manual and docs from your OS how to use sendmail/postfix/exim (or whatever your OS is using).

because nothing refers specifically to xampp for linux...

XAMPP is just using the mailserver from the OS.
--> it is calling the binary "/usr/sbin/sendmail". You can change the name/path in "php.ini" if needed.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maiadrupal » 23. September 2008 10:03

thank you Wiedmann...
Wiedmann wrote:
I fixed the httpd.conf

What exactly?
(XAMPP/Apache sepecific: Verify that the mod_rewrite module is enabled.)

sorry, here it is the info I made a number of tries:

in /opt/lampp/etc/httpd.conf...
- I moved "LoadModule rewrite_module modules/mod_rewrite.so" below "LoadModule cache_module modules/mod_cache.so" according http://drupal.org/node/43545 (Clean URL support in XAMPP)
- I added
<Directory "/opt/lampp/htdocs/drupal">
AllowOverride All
Order allow,deny
Allow from all
</Directory>
- I tried to modify mime_module section like this <IfModule mime_module> ...AddModule mod_rewrite.c </IfModule>
...and I commented it because apache didn't start
- I tried to add "AddModule mod_rewrite.c" below the new line "LoadModule rewrite_module modules/mod_rewrite.so", but I commented it for the same reason

in /opt/lampp/etc/extra/httpd-xampp.conf...
- I added
<Directory "opt/lampp/htdocs/drupal/">
AllowOverride All
Order allow,deny
Allow from all
</Directory>
...and I commented it because the browser didn't find the drupal directory

anyway, drupal still says that clean url are not supported, I'm sorry
2 -...local mail server

A mailserver is part of your Linux distribution. So, read the manual and docs from your OS how to use sendmail/postfix/exim (or whatever your OS is using).
...xampp for linux...

XAMPP is just using the mailserver from the OS.
--> it is calling the binary "/usr/sbin/sendmail". You can change the name/path in "php.ini" if needed.

I will try this as soon as possible

thank you again

maia
maiadrupal
 
Posts: 4
Joined: 23. September 2008 04:56

Postby Wiedmann » 23. September 2008 10:25

I moved "LoadModule rewrite_module modules/mod_rewrite.so" below "LoadModule cache_module modules/mod_cache.so" according http://drupal.org/node/43545 (Clean URL support in XAMPP)

You must not move this line. Just make sure there is no "#" in front of this line. (according to the above link)

You can verify if mod_rewrite is loaded with e.g. phpinfo():
(apache2handler --> Loaded Modules)

- I added
<Directory "/opt/lampp/htdocs/drupal">
AllowOverride All
Order allow,deny
Allow from all
</Directory>

That's not necessary (remove them). Just make sure, that "AllowOverride" is set to "All" for the <Directory "/opt/lampp/htdocs"> in "httpd.conf".


Only the above 2 things are necessary for general pretty URL support (Apache specific).

anyway, drupal still says that clean url are not supported, I'm sorry

Further problems with Drupal setup and installation must be discussed in a Drupal forum.
(We don't know what Drupal is testing at this point.)

I tried to modify mime_module section like this <IfModule mime_module> ...AddModule mod_rewrite.c </IfModule>
...and I commented it because apache didn't start
- I tried to add "AddModule mod_rewrite.c" below the new line "LoadModule rewrite_module modules/mod_rewrite.so", but I commented it for the same reason

Revert these changes: not necessary.

n /opt/lampp/etc/extra/httpd-xampp.conf...
- I added
<Directory "opt/lampp/htdocs/drupal/">
AllowOverride All
Order allow,deny
Allow from all
</Directory>
...and I commented it because the browser didn't find the drupal directory

Revert these changes: not necessary.
(don't change this file without knowledge)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maiadrupal » 23. September 2008 14:14

hello, thank you very much for you kind and quick reply...

well, I didn't touch the config files, from my last comment here, but I have been forced to a new installation, because of an issue with the blocks' configuration that sincerely I don't know how to fix

when I did the new installation, I found the "clean urls" automagically enabled in the drupal installation wizard, so now they works!

I had tried to re-test for clean urls in the first post installation, but they never could be enabled... so the apache config worked (although it is wrong, as you noticed) but it was not recognized by the installed drupal

obviously I can't explain this, but I conclude that for newbies with xampp+drupal, it is better to correctly set register_globals, memory_limit and mod_rewrite before to start the installation

I know that this is specific drupal topic, but I think that xampp is quite important to test and develop a site with drupal

for the same reason, I think I would be a good idea if the linux version of xampp had a built in mail server as the windows version has

in the end, it seems that drupal is quite delicate in front of a clumsy newbie as I am :-)

thank you very much

maia
maiadrupal
 
Posts: 4
Joined: 23. September 2008 04:56

postfix

Postby maiadrupal » 01. October 2008 10:41

hello,

while I managed to use the clean url, I also got the mail support for drupal in linux ubuntu

the best solution for me is "postfix"

the only thing you need is one package sudo apt-get install postfix, and the mail server (mail transport agent) is immediately available to drupal (no restart are needed)

thanks, hope this helps
maiadrupal
 
Posts: 4
Joined: 23. September 2008 04:56


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests