MySQL fails, reports no error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL fails, reports no error

Postby LeFou » 10. September 2008 16:43

I'm attempting to enable innoDB tables, so i made some changes to my.cnf. This cause problems, so I commented out my changes and am back to the default my.cnf

However, lampp will no longer start mysql and i found this in the
/localhost.localdomain.err

Code: Select all
max_connections=100
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 76399 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=(nil)
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...


after this it has a stacktrace, and refers me to what looks like an hourlong process for making sense of stacktraces.

It also refers me to
http://www.mysql.com/doc/en/Crashing.html

which doesn't exist
LeFou
 
Posts: 3
Joined: 01. May 2007 20:16

Postby LeFou » 10. September 2008 17:22

i think i have resolved part of this; after commenting my changes i'd forgotten to un-comment skip-innodb.

i'm back up and running but still want to enable innoDB, with innodb_file_per_table. I'm scared to try again, though ..
LeFou
 
Posts: 3
Joined: 01. May 2007 20:16


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests