Question regarding the installation of Ruby on Rails

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Question regarding the installation of Ruby on Rails

Postby barrymc » 23. June 2008 00:07

Hi,

I've got XAMPP installed, and I want to install mod_passenger for ruby on rails deployment through Apache.

I've encountered a few problems though.

This code is during the passenger-install-apache2-module
Code: Select all
Checking for required software...

 * GNU C++ compiler... found at /usr/bin/g++
 * Ruby development headers... found
 * OpenSSL support for Ruby... found
 * RubyGems... found
 * Rake... found at /usr/local/bin/rake
 * Apache 2... not found
 * Apache 2 development headers... found at /opt/lampp/bin/apxs
 * Apache Portable Runtime (APR) development headers... found at /opt/lampp/bin/apr-1-config
 * fastthread... found

Some required software is not installed.
But don't worry, this installer will tell you how to install them.

Press Enter to continue, or Ctrl-C to abort.


As you can see, Apache 2 was not found during the attempted passenger install script. If anyone could help me out with this install it would be great, I really need to get it working. I'm assuming it's something as simple as a shell variable but I've no idea what to set or what to look for.

Thanks.
barrymc
 
Posts: 1
Joined: 22. June 2008 23:59

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests