bcompiler-0.8 and 1.6.6 compatibility issue?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

bcompiler-0.8 and 1.6.6 compatibility issue?

Postby ehelwig » 07. April 2008 18:33

I currently have an installation of xampp running on Centos 4.5. I am trying to add the bcompiler extension per documentation. When I restart lamp, it get the following error:

Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/bcompiler.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/bcompiler.so: cannot open shared object file: No such file or directory in Unknown on line 0

I verfied the shared object and paths are correct. I am looking for any direction or advise on resolving my issue. Thanks in advance.
ehelwig
 
Posts: 5
Joined: 07. April 2008 18:26

Postby Wiedmann » 07. April 2008 18:35

trying to add the bcompiler extension per documentation.

How have you add it exactly?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ehelwig » 07. April 2008 18:39

Thanks for the quick response Wiedman:

1. Download the extension "bcompiler" from http://www.pecl.php.net/package/bcompiler

2. To add it, did the following

/opt/lampp/bin/phpize
./configure --with-php-config=/opt/lampp/bin/php-config
make

3. Copied the newly built shared object to my extension directory.


4 Edited /opt/lampp/etc/php.ini and add a line

extension=bcompiler.so

5. Restart the webserver

/opt/lampp/lampp stop
/opt/lampp/lampp start
ehelwig
 
Posts: 5
Joined: 07. April 2008 18:26

Postby Wiedmann » 07. April 2008 18:51

Looks good (of course I have no Linux...)

Maybe you are missing some dependices for bcompiler. AFAIK you can test this with:
ldd /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/bcompiler.so
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ehelwig » 07. April 2008 18:58

That is the same conclusion that I came to. I dug around to make sure bzip2 was good, and kind of threw my hands up at that point....Here my ldd output, which I think looks good as well:

ldd /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/bcompiler.so
libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x0000002a95688000)
libc.so.6 => /lib64/tls/libc.so.6 (0x0000002a95797000)
/lib64/ld-linux-x86-64.so.2 (0x000000552aaaa000)
ehelwig
 
Posts: 5
Joined: 07. April 2008 18:26

Postby Wiedmann » 07. April 2008 19:06

which I think looks good as well:

IMHO this looks not good. Because your 32bit bcompiler (XAMPP is 32bit) wants load other 64bit libs.

(BTW: is libbz2 not part of XAMP ad should be loaded from /opt/lampp/lib?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ehelwig » 07. April 2008 19:21

Ooops, my goof. Thanks for pointing out the 64-bit problem. So I must have assumed that the libbz2 was installed with my installation as well with /opt/lampp since I found bzip2 under both paths. Any suggestion on a workaround?
ehelwig
 
Posts: 5
Joined: 07. April 2008 18:26

Postby ehelwig » 08. April 2008 22:00

Wiedmann,

Problem solved by loading 32-bit version of OS and bcomplier works as published.
ehelwig
 
Posts: 5
Joined: 07. April 2008 18:26


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests