undefined method DOMXPath::evaluate() using PHP 5

Problems with the Linux version of XAMPP, questions, comments, and anything related.

undefined method DOMXPath::evaluate() using PHP 5

Postby GetFree » 31. March 2008 06:33

Hi,
I have LAMPP with php5 and I get the following error:

Fatal error: Call to undefined method DOMXPath::evaluate()

According to PHP documentation this is impossible because that method should exist in PHP 5.
Any idea what would be the problem??

Probably, the problem doesn't concern xampp, I dont know. But may be installing a new PHP version solves the problem.

So my question is: How can I upgrade to PHP 5.2 in my particular case, i.e. LAMP package with apache 2 + PHP 5 already installed and running ??
Should I follow the standard procedure datailed in PHP's website ??

Thanks in advance.
GetFree
 
Posts: 19
Joined: 18. October 2006 04:55

Postby Wiedmann » 31. March 2008 06:56

According to PHP documentation this is impossible because that method should exist in PHP 5.

Sure?
http://de.php.net/manual/en/function.dom-domxpath-evaluate.php wrote:(No version information available, might be only in CVS)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby GetFree » 31. March 2008 07:36

Yeah, but the same says for all DOM methods.

Anyway, this problem turns out to be a bug:
http://bugs.php.net/bug.php?id=31593

So my only alternative now is to upgrade to PHP 5.2.

I'm afraid of upgrading just like that.
LAMPP is supposed to be a different when it comes to directories and file locations, so I dont know whether following the steps in here http://www.php.net/manual/en/install.unix.apache2.php will do fine or not.

Anyone knows?
GetFree
 
Posts: 19
Joined: 18. October 2006 04:55


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests