[Solved] 403 Forbidden error in Ubuntu Hardy

Problems with the Linux version of XAMPP, questions, comments, and anything related.

[Solved] 403 Forbidden error in Ubuntu Hardy

Postby unabatedshagie » 24. February 2008 15:35

I've been running xampp with no problems on ubuntu hardy for a month or two.

I haven't had the need to use it for maybe the last week or so but now when I start xampp and try to view 127.0.0.1/alex in firefox I get a 403 Forbidden error page.

I haven't touched xampp or my webdesign folder in that time.

I have a symlink from /home/alex/WebDesign to /opt/lampp/htdocs/alex which as I said was working fine until I tried it today.

Anyone have any ideas as to why this would suddenly stop working?

I was running 1.6.5a and when that didn't work I downloaded 1.6.6
Last edited by unabatedshagie on 26. February 2008 15:47, edited 1 time in total.
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby Wiedmann » 24. February 2008 19:37

I get a 403 Forbidden error page.

"error_log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby unabatedshagie » 24. February 2008 21:33

Oh sorry, totally forgot to add it.
Code: Select all
[Sun Feb 24 14:01:33 2008] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 24 14:01:33 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:01:33 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:01:33 2008] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 24 14:01:33 2008] [notice] Digest: done
[Sun Feb 24 14:01:34 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:01:34 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:01:34 2008] [notice] Apache/2.2.8 (Unix) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8e PHP/5.2.5 mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.10.0 configured -- resuming normal operations
[Sun Feb 24 14:02:03 2008] [error] [client 127.0.0.1] File does not exist: /opt/lampp/htdocs/alex
[Sun Feb 24 14:03:03 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:04:21 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:15:12 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:19:12 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:19:13 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:19:45 2008] [notice] caught SIGTERM, shutting down
[Sun Feb 24 14:19:53 2008] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 24 14:19:54 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:19:54 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:19:54 2008] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 24 14:19:54 2008] [notice] Digest: done
[Sun Feb 24 14:19:55 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:19:55 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:19:55 2008] [notice] Apache/2.2.8 (Unix) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8e PHP/5.2.5 mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.10.0 configured -- resuming normal operations
[Sun Feb 24 14:20:00 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:20:02 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:21:54 2008] [notice] caught SIGTERM, shutting down
[Sun Feb 24 14:22:28 2008] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 24 14:22:28 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:22:28 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:22:28 2008] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 24 14:22:28 2008] [notice] Digest: done
[Sun Feb 24 14:22:29 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:22:29 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:22:29 2008] [notice] Apache/2.2.8 (Unix) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8e PHP/5.2.5 mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.10.0 configured -- resuming normal operations
[Sun Feb 24 14:22:33 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:22:35 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:23:24 2008] [notice] caught SIGTERM, shutting down
[Sun Feb 24 14:25:46 2008] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 24 14:25:46 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:25:46 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:25:46 2008] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 24 14:25:46 2008] [notice] Digest: done
[Sun Feb 24 14:25:47 2008] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 24 14:25:47 2008] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Feb 24 14:25:47 2008] [notice] Apache/2.2.8 (Unix) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8e PHP/5.2.5 mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.10.0 configured -- resuming normal operations
[Sun Feb 24 14:26:25 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
[Sun Feb 24 14:30:28 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby unabatedshagie » 26. February 2008 14:06

Nobody got any ideas on what the problem could be?
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby Wiedmann » 26. February 2008 14:29

Code: Select all
[Sun Feb 24 14:02:03 2008] [error] [client 127.0.0.1] File does not exist: /opt/lampp/htdocs/alex
[Sun Feb 24 14:03:03 2008] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/alex

a) In "httpd.conf" you must define the option "FollowSymLinks" for your htdocs (IMHO that's the default setting). The same, if you set options in a ".htaccess" file in your htdocs directory.

b) the Apache user/group (IMHO "nobody"), must have enough rights to access the symlink (the target directory).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby unabatedshagie » 26. February 2008 15:23

a) That option is already defined in httpd.conf and I don't have a .htaccess file in any of my folders.

b) I don't seem to have either an apache or nobody group.

These are all the groups I have on my machine.

http://picasaweb.google.com/alex.paterson/Screenshots/photo#5171294207575999666
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby Wiedmann » 26. February 2008 15:34

b) I don't seem to have either an apache or nobody group.

But you can set rights for one user, a group, or all:
Have "all" enough rights on "/home", "/home/alex" and "/home/alex/WebDesign" (the target of your symlink)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby unabatedshagie » 26. February 2008 15:46

Hmmm, the permissions must have been changed on my home folder during some update with hardy, others didn't have access to my home folder so I changed it to allow them access and now everything works.

Thanks for your help.
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Re: [Solved] 403 Forbidden error in Ubuntu Hardy

Postby hughitt1 » 24. January 2011 21:37

Hmm. I know this thread is a bit old, but I'm having a similar problem and was wondering if someone might be able to shed some light.

I have two directories that I want to symlink to in my document root, one in /mnt/another/partition and another in my home directory, /home/user/dev. I am able to access the the contents on the second partition (/mnt/another/partition), but get a 403 error ("Symbolic link not allowed or link target not accessible: /srv/http/dev") when attempting to access the sym link to the home directory.

The only difference seems to be the ownership: the directory on the external partition has access rights:
drwxr-xr-x user 1000 4096 Jan 12 09:40 some_folder

and this works fine. The directory within /home, however, was set to:
drwxr-xr-x user users 4096 Jan 21 20:30 dev

I tried changing the group to "http" (Apache), but that did not work either.

Any suggestions? Any help would be greatly appreciated.

Thanks!
Keith
hughitt1
 
Posts: 1
Joined: 24. January 2011 21:28


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests