XAMPP and Phpmyadmin

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP and Phpmyadmin

Postby myth2112 » 31. January 2008 06:16

Hello all!

I have been having some issues with a previously smooth running install of XXAMP. I'm currently running Ubuntu.

My phpmyadmin is not currently working, when opened I recieve this error:

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)


And when starting XXAMP, I see this in the command line:

Starting XAMPP for Linux 1.5.4a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
/opt/lampp/bin/mysql.server: 84: source: not found
XAMPP for Linux started.


I believe MYSQL is not starting, and it is most likely file permissions related, but am uncertain of how to proceed. Does anyone have any advice?

Thanks!
Last edited by myth2112 on 01. February 2008 06:28, edited 1 time in total.
myth2112
 
Posts: 4
Joined: 30. January 2008 16:34

Postby myth2112 » 01. February 2008 06:26

Is there a default setting for all of the directories and files in xxamp? Is is 755?

I have been messing around and changing the permissions in some files and directories, but no joy.

Im still getting the following error on startup.

/opt/lampp/bin/mysql.server: 84: source: not found


but all else seems to be working. Does anyone have any ideas?

Thanks
myth2112
 
Posts: 4
Joined: 30. January 2008 16:34

Postby myth2112 » 02. February 2008 17:13

Figured it out:

sudo chown -R nobody:nogroup /opt/lampp


does the trick. I had /opt/lampp/ as root:root.

However when restarting, I still get these messages:

:/opt/lampp$ sudo /opt/lampp/lampp restart
Stopping XAMPP for Linux 1.5.4a...
XAMPP: Stopping Apache with SSL...
XAMPP: XAMPP-MySQL is not running.
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.5.4a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
/opt/lampp/bin/mysql.server: 84: source: not found
XAMPP for Linux started.
:/opt/lampp$ /opt/lampp/bin/mysql.server: 334: log_success_msg: not found


but it works some how.
myth2112
 
Posts: 4
Joined: 30. January 2008 16:34


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests