pear reading wrong version of php

Problems with the Linux version of XAMPP, questions, comments, and anything related.

pear reading wrong version of php

Postby sytram » 29. January 2008 20:57

I am installing magento on a system running XAMPP for Linux. When I try to follow their commands to manage downloads & upgrades manually:
/pear mage-setup
./pear install mage-core/Mage_Pear_Helpers mage-core/Lib_ZF mage-core/Lib_Varien
./pear install mage-core/Mage_All mage-core/Interface_Install_Default
./pear install mage-core/Interface_Frontend_Default mage-core/Interface_Adminhtml_Default

When I get to the 3rd command I get an error message of:
magento]# ./pear install mage-core/Mage_All mage-core/Interface_Install_Default
mage-core/Mage_All requires PHP (version >= 5.2.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 4.3.9
mage-core/Mage_All requires PHP extension "pdo_mysql"
mage-core/Mage_All requires PHP extension "SimpleXML"
mage-core/Mage_All requires PHP extension "dom"
mage-core/Mage_All requires PHP extension "SPL"
mage-core/Mage_All requires PHP extension "mcrypt"
mage-core/Interface_Install_Default requires PHP (version >= 5.2.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 4.3.9
mage-core/Interface_Install_Default requires package "mage-core/Mage_All" (version >= 0.7.15480)
mage-core/Mage_Pear_Helpers requires PHP (version >= 5.2.0, version <= 6.0.0), installed version is 4.3.9
mage-core/Lib_Varien requires PHP (version >= 5.2.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 4.3.9
mage-core/Lib_Varien requires package "mage-core/Mage_Pear_Helpers" (version >= 0.7.15480)
mage-core/Lib_Varien requires PHP extension "pdo_mysql"
mage-core/Lib_Varien requires PHP extension "SimpleXML"
mage-core/Lib_Varien requires PHP extension "dom"
mage-core/Lib_Varien requires PHP extension "SPL"
mage-core/Lib_Varien requires PHP extension "mcrypt"
mage-core/Lib_ZF requires PHP (version >= 5.2.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 4.3.9
mage-core/Lib_ZF requires package "mage-core/Mage_Pear_Helpers" (version >= 0.7.15480)
No valid packages found
install failed

but when I check phpinfo() it says I have version 5.2.5 installed
sytram
 
Posts: 1
Joined: 29. January 2008 20:48

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests