don't have permission to access ... on the server

Problems with the Linux version of XAMPP, questions, comments, and anything related.

don't have permission to access ... on the server

Postby unabatedshagie » 10. January 2008 06:23

Just freshly installed gutsy and downloaded the latest version of xampp (1.6.5a), "installed" fine and works fine.

Now previously I have been able to run the following command
Code: Select all
sudo ln -s /home/alex/WebDesign /opt/lampp/htdocs/%USER

and type localhost/alex into firefox to view the files in the folder.

Now I'm getting an error saying that I don't have permission to access the files on the server.

As far as I can tell I have the correct permissions on the folder (I haven't changed the permission on the WebDesign folder since I backed it up and restored it)

Has something changed with xampp since the last version? (before the os re-install I was using a slightly older version of xampp, think it was 1.6.4)
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby unabatedshagie » 11. January 2008 14:18

Sorry to bump this but it's a semi-urgent problem.

Does nobody have any ideas as to why I can't symlink a folder from my home directory to the htdocs folder or why apache is saying I don't have permission to access the folder?
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby madfrog » 12. January 2008 14:32

Hey,

I had the same problem but by searching through the apache docs, I found the answer. I can only suggest you do the same if you are not already doing so.

I went into /opt/lampp/etc/httpd.conf.

Where it said:

# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride None
#XAMPP
#Order deny,allow
#Deny from all
</Directory>


I removed the '#' symbol' in front of 'Order deny,allow' so that it looks like that:

# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride None
#XAMPP
Order deny,allow
#Deny from all
</Directory>


Then, I restarted xampp and my problem was fixed.
I don't know if it will work for you or if it's the best way to do, but it's worth trying.
madfrog
 
Posts: 2
Joined: 12. January 2008 14:13

Postby unabatedshagie » 12. January 2008 18:14

That doesn't make any difference.

What I can't understand is why it used to work and now after a reinstall it doesn't.
unabatedshagie
 
Posts: 8
Joined: 10. January 2008 06:19

Postby madfrog » 13. January 2008 00:22

What I did was simply authorizing everyone to access, from the browser, all the directories unless explicitly denied.
This is not the most secure way of doing of course, but I'm very happy with this.
Re-installing xampp will not improve things, simply reset everything back to default. It's only a permissions problem.
madfrog
 
Posts: 2
Joined: 12. January 2008 14:13


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests