Bug: 1.6.5. problem with phpMyAdmin

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Bug: 1.6.5. problem with phpMyAdmin

Postby vidak » 25. December 2007 07:31

I found problem with phpMyAdmin.

with version 1.6.4. everything is OK, but with 1.6.5. there is an error in mysql sintaks. It seems there is no table in phpmyadmin database.

I downgrade my xampp to 1.6.4. and everything is normal.
User avatar
vidak
 
Posts: 3
Joined: 25. December 2007 07:26

Postby skuipers » 25. December 2007 08:29

Sorry to post in English - but this could be an emergency.

I agree with your findings. See also my post in the English section.

As far as I can see it is not necessary to downgrade to XAMPP 1.6.4 again. Replacing the 1.6.5 phpMyAdmin config.inc.php with the "old" 1.6.4 one did the trick for me.
skuipers
 
Posts: 99
Joined: 21. January 2005 16:27
Location: The Netherlands

Postby Oswald » 25. December 2007 11:41

Dear Vidak and Skuipers!

Thanks for pointing at that issue. Please use or upgrade to 1.6.5a to fix this problem.

Thanks again and many greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sari42 » 25. December 2007 19:55

if only the phpmyadmin/config.inc.php is broken you can use phpmyadmin/scripts/setup.php to create a valid config file
or even use your texteditor and save this
Code: Select all
<?php
$cfg['blowfish_secret'] = 'anything (but less than 47 characters)';
// only needed for obfuscating user-name/pw if auth_type = cookie

$i = 0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'cookie';
// gives better hints from mysql than http

$cfg['Servers'][$i]['extension'] = 'mysqli';
// for advanced features

// see http://wiki.cihar.com/pma/config.inc.php
// and http://wiki.cihar.com/pma/Quick_Install#Configuration
?>
later you can amend it according your needs, e.g., "controlluser"... (see config.sample.inc.php)
HTH
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby vidak » 26. December 2007 02:16

I am new in linux and xampp and my German is very, very bad. My Engish is bad to but that was only way to sad something about the problem.
I agree it wasn`t nessary to downgrade to 1.6.4.

Thank`s for advising me

Vidak
User avatar
vidak
 
Posts: 3
Joined: 25. December 2007 07:26


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests