MANDRIVA 2008 _ aPACHE2 _XAMPP together

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MANDRIVA 2008 _ aPACHE2 _XAMPP together

Postby inidLinux » 22. December 2007 06:23

Hello All

I have following Setup

Systems Default RPM based Apache2+mysql+php5 running fine on their own default ports.

I required to run PHP4 we pages , so i installed and Run Xampp well .

I modified the Ports of The

vi /opt/lampp/etc/ my.cnf httpd.conf php.ini and made the following chages in their Port Numbers only .

Systems Default Apache Port : 80
Systems Default mysql Port : 3306


Xampp modified Apache Port : 8090
Xampp modified Mysql Port : 3307

Then i switch back to php4 after restarting the lampp.

Then i did following chages in /etc/rc.d/rc.local

/opt/lampp/lampp start
/opt/lampp/lampp php4

So finally i rebooted the Machine to Check that all may work as expected .

Now after rebooting i tried

http://locahost

IT works

means default Systems apache running fine

But when i treid

http://locahost:8090

Page Not Found Nothing comes as expected I must be greeted with default Xampp Page .
Then I check

/opt/lampp/lampp start

Another web Server is running Error comes .

But How it happend as i am running both on different Ports

Kindly Help me may i am missing some things .

Thanks to all of you
inidLinux
 
Posts: 4
Joined: 21. December 2007 18:53

Postby Scory » 22. December 2007 14:07

Run "/opt/lampp/lampp start" in a shell and you will see the reason - the script detects that there is already a process apache running and quits with an error message.

You must change the order of the starting programms, first start lampp and after that start your standard apache. Or dont use the lampp start/stop script and start the corresponding apache directly.

Or dont start your existing apache, mysql etc. as you dont need it.
Scory
 

Reply

Postby inidLinux » 23. December 2007 06:33

Thanks Scory ,

But as i mention we are already using that apache integrating with php5 and mysql 5.x as a systems default for running php5 with all the module support along with mono and asp fotn is also running on the same server .

Now for php4 specially i required Xampp , so i worked it out .

Now all is fine only its detecting my previous apache .

Now i made following changes .

vi /etc/rc.d/rc.local

/opt/lampp/lampp start
/opt/lampp/lampp php4

service httpd start
service mysqld start

exit the file .

Then i tried 192.168.10.2 on browser
as 80 is for default for systems apache and 8090 is for Xampp.

not when i try

http://192.168.10.2

some time pages comes and and some time error comes .
when page comes that time 8090 is not greeting with Xampp
when page not comes of "IT wroks" then Xampp is greeting well

So for making both come

i again needs to

do all manually as you said stop all and then start first Xampp and then Systems Default
Apache and Mysqld .

then all works fine.

But for doing this all the time i need to be on sever .Which is really not possible as its master server without Monitor , so i need to check the things by doing ssh every time .

Ok If you can suggest me some way out then kindly help ,a s i too trying hard to make all working without my server manual changes.

Thanks to all
inidLinux
 
Posts: 4
Joined: 21. December 2007 18:53


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests