Downgrade mysql 5 to 4?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Downgrade mysql 5 to 4?

Postby pinoguin » 23. November 2007 14:15

I tried looking around for a way to do this but so far I found none,

does anyone here know how to use mysql 4.1 instead of 5?
Posts: 1
Joined: 23. November 2007 14:04
Location: Philippines

Postby scranmer » 28. November 2007 13:12

I too have tried this and to the most part I’ve been successful. To do this just download 4.1.22 from the mySQL site and copy the bits into the same place as in the existing xampp.

This all runs but phpmyadmin gives me the warning :-
Your PHP MySQL library version 5.0.45 differs from your MySQL server version 4.1.22. This may cause unpredictable behavior.

I’ve downloaded the php_mysql.dll & php_mysqli.dll for 4.1 and dropped them in the folder ext but then I get apache error :-

PHP Warning:
PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0

anyone any ideas please?


Posts: 26
Joined: 20. May 2004 14:59
Location: UK, Southport

Postby Vger » 28. November 2007 14:12

What I did (eventually) which resolved this problem was to install XAMPP as normal and then download a Windows Installer (.msi file type) version of MySQL 4.1 - and just ran it. It overwrote MySQL 5 and got rid of any error messages I'd had before.

I'm sorry but I did not keep the link to the .msi download of MySQL 4.1

Posts: 21
Joined: 16. June 2005 23:46
Location: United Kingdom

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests