Error :/

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error :/

Postby Mike_DK » 08. October 2003 04:30

Hi.

First off, nice work guys. It's easy to install and start, which is good. But I have a problem that I hope you can help with. It install and runs fine. But when i try to use the mysql database for installing a forum, the forum works for about 10 minutes, and then i get this error all the sudden:

Code: Select all
mySQL query error: SELECT f.*, c.id as cat_id, c.position as cat_position, c.state as cat_state, c.name as cat_name, c.description as cat_desc,
                 c.image, c.url, m.member_name as mod_name, m.member_id as mod_id, m.is_group, m.group_id, m.group_name, m.mid
                 FROM ibf_forums f, ibf_categories c
                   LEFT JOIN ibf_moderators m ON (f.id=m.forum_id)
                 WHERE c.id=f.category
                 ORDER BY c.position, f.position

mySQL error: Can't create/write to file '/root/tmp/#sql_1dfe_0.MYI' (Errcode: 13)
mySQL error code:
Date: Wednesday 08th of October 2003 05:25:42 AM


I tried reinstalling the forum 3 times, and installing another forum 2 times. It does the same every time. It works for about 10 minutes and then people get that error. Forums i tried with are Invision forum and phpbb forum. I use the 1.3 version of your package.
Mike_DK
 

Postby Mike_DK » 08. October 2003 04:34

I forgot to mention that i run it on linux (Mandrake 9.1).
Mike_DK
 

Postby Oswald » 08. October 2003 08:35

Dear Mike!

Error 13 means "Permission denied". Very strange in this scenario.

Three questions:

Could you please call ps -aux | egrep mysql and post the output?
Did you change the my.cnf file in any way?
Exsits the directory /root/tmp? (Btw I never heard about a tmp directorty besides the /root directory. Are you sure about the error message or is it just a typo)

Many greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby esCmo » 08. October 2003 13:58

Is it possible you uncommented Line 43 (#tmpdir = /tmp/) and changed it to /root/tmp/ instead of /tmp/ ? And this directory either doesn't exist or user 'nobody' (or your apache user) hasn't got writing access to it??

Just my guess!
User avatar
esCmo
 
Posts: 59
Joined: 21. September 2003 22:01


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests