Backup problem after patching from 1.6.3b to 1.6.4

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Backup problem after patching from 1.6.3b to 1.6.4

Postby Siggi_Starr » 09. November 2007 15:21

After installing the 1.6.3b to 1.6.4 patch the backup scripts don't work.
It failes after exporting the databases with this error:
"mysqldump: Got error: 1017: Can't find file: 'pma_bookmark' (errno: 2) when using LOCK TABLES"

I read this in the Relase Notes of the patch:
- Renamed phpMyAdmin's MySQL tables to lowercase to better fit its defaults settings

In the phpmyadmin database I now have uppercase tables and lowercase tables, example: pma_bookmark and PMA_bookmark.
phpmyadmin says that pma_bookmark is in use but it cant find the file pma_bookmark, the PMA_bookmark table has data and is in use and is being updated.

What actualy was supposed to happen during this patch? Can I delete these lowercase tables as they clearly has no data and are causing the backup scripts to fail?
Siggi_Starr
 
Posts: 4
Joined: 31. May 2007 11:42

Postby Siggi_Starr » 13. November 2007 17:07

I belive I found the problem. The database files for phpmyadmin had lowercase endings:

pma_bookmark.myi
pma_bookmark.myd

Copied the files to a uppercase ending:
pma_bookmark.MYI
pma_bookmark.MYD

Seems to do the trick.
I didn't change the pma_bookmark.frm as it seemd all the other databases had lowercase endings on the .frm files too.

PS!
I had to do this to all the files for phpmyadmin database, not just the pma_bookmark.
Siggi_Starr
 
Posts: 4
Joined: 31. May 2007 11:42

Postby Siggi_Starr » 13. November 2007 17:10

I still have double up on tables, but considering that they only use 1M of space and that the backup script is working again...well I don't care :)
Siggi_Starr
 
Posts: 4
Joined: 31. May 2007 11:42


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests