Rewrite not working on Debian

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Rewrite not working on Debian

Postby Faith » 28. October 2007 17:34

Hi All!

I did installed Debian Linux on a VMWare Box, then I installed XAMP.

Everything looked fine.

Then I copied one of my sites from the real server to this machine, where I am used rewrite to hide index.php, but it looks that rewrite does not work totally. I switched on logging to level 9, but notting is written to the log file. It was only created, but nothing is inserted to it.

Here are my settings from apache httpd.conf:

Code: Select all
<IfModule rewrite_module>
  RewriteEngine On
  RewriteLog "/opt/logs/apache-rewrite.log"
  RewriteLogLevel 9
</IfModule>


and here’s a piece from my .htaccess:

Code: Select all
RewriteEngine on
RewriteCond $1 !^(flash|images|img|themes|index\.htm|404\.html|blank\.html|overload\.html|overkill\.html|favicon\.ico|index\.php|path\.php)
RewriteRule ^(.*)$ /index.php/$1 [L]
ErrorDocument 404 /404.html


with no effect on the url.

Exactly this is working on my professionaly hosted system. But I am stucked with this here. I tried everything I can, but no way to get it work.

I hope somebody will help me!

Thanks in advance!

Faith
Faith
 
Posts: 2
Joined: 28. October 2007 17:23

Postby Wiedmann » 28. October 2007 17:39

and here’s a piece from my .htaccess:

Is it allowed to use a ".htaccess" file?
--> AllowOverride
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Faith » 28. October 2007 18:46

THANKS A LOT!

That was the problem!!!
Faith
 
Posts: 2
Joined: 28. October 2007 17:23


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests