XAMPP Reverse Proxy to IIS w/ SSL and Exchange

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP Reverse Proxy to IIS w/ SSL and Exchange

Postby slowyaroll » 08. October 2007 22:19

I'm a bit stumped, but here goes my problem.

I have XAMPP setup with several virtual hosts, all of which work. These virtual hosts basically resolve external requests and do a ReverseProxy to various internal servers.

I now need to reverse proxy to an internal server running IIS. IIS is running with SSL. I've tried a couple of different setups with the virtual host. One setup ends up prompting me for the XAMPP User password. The other setup passes through to IIS, but returns a 404 error. I'm guessing because the certificate isn't being accepted somewhere?

VirtualHost setup that returns 404 error
Code: Select all
<VirtualHost careers.domainname.org:80>
    ServerAdmin xampp@domainname.org
#   DocumentRoot /www/docs/dummy-host2.example.com
    ServerName careers.domainname.org
    ErrorLog logs/careers.domainame.org-error_log
    CustomLog logs/careers.domainname.org-access_log common

#   SSLRequireSSL

#   ProxyRequests Off
#   ProxyPass / http://10.1.0.10/
#   ProxyPassReverse / http://10.1.0.10/

#   Redirects to Exchange b/c HR IIS app is not secured.  Remove below lines on$
    ProxyRequests Off
    AllowCONNECT 80 443 563
    ProxyPass / http://192.0.0.13/
    ProxyPassReverse / http://192.0.0.13/
#    ProxyPassReverse https://192.0.0.13/ /
</VirtualHost>


VirtualHost setup that prompts for XAMPP user password | The only change was that AllowCONNECT was commented out
Code: Select all
<VirtualHost careers.domainname.org:80>
    ServerAdmin xampp@domainname.org
#   DocumentRoot /www/docs/dummy-host2.example.com
    ServerName careers.domainname.org
    ErrorLog logs/careers.domainname.org-error_log
    CustomLog logs/careers.domainname.org-access_log common

#   SSLRequireSSL

#   ProxyRequests Off
#   ProxyPass / http://10.1.0.10/
#   ProxyPassReverse / http://10.1.0.10/

#   Redirects to Exchange b/c HR IIS app is not secured.  Remove below lines on$
    ProxyRequests Off
#   AllowCONNECT 80 443 563
    ProxyPass / http://192.0.0.13/
    ProxyPassReverse / http://192.0.0.13/
#    ProxyPassReverse https://192.0.0.13/ /
</VirtualHost>


Any help will be very much appreciated because I'm totally stumped. :oops:
Last edited by slowyaroll on 09. October 2007 16:03, edited 1 time in total.
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]

Postby Wiedmann » 08. October 2007 22:28

Code: Select all
ProxyPass / http://192.0.0.13/

IIS is running with SSL

In this case you must proxy your requests to "https" and not http".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby slowyaroll » 08. October 2007 22:35

I just tried that, and it still prompts me for the XAMPP user's password. When I click "cancel" it resolves back to http://careers.domainname.org/xampp
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]

Postby Wiedmann » 08. October 2007 22:38

When I click "cancel" it resolves back to http://careers.domainname.org/xampp

Is this host "careers.domainname.org" on your localhost (server and browser are the same pc)? Maybe you should clear your browser cache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby slowyaroll » 08. October 2007 22:49

I'm testing everything from a separate machine. careers.domainname.org is a Linux box. . . http://192.0.0.13 is a Windows 2003 box

I cleared my cache, but still no luck. I really do appreciate your help with this.

**I've sent you a private message also.
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]

Postby slowyaroll » 09. October 2007 01:29

I've found some documentation that may help me. . .once I figure out the translation.

http://media.plominski.de/docs/Xampp-Re ... OWA-09.pdf

http://media.plominski.de/docs/Xampp-Re ... TPS-12.pdf

Any help is welcome :)
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]

Postby slowyaroll » 11. October 2007 15:37

Still working at it. . .but stumped with the following error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /xampp/.
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]

Postby slowyaroll » 12. October 2007 22:13

I've gotten a bit further. For some reason (more specifically, I can't figure out) why the http requests keep defaulting to XAMPP's configuration. When I commented out XAMPP's VirtualHost directives, the site went through correctly.

Although I do prefer using XAMPP, I think for my purposes in this specific case, it'll be best to have a regular Ubuntu install with Apache.

I'll keep tinkering until I find out a definitely correction.
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests