mysqld_safe and new lampp installation

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mysqld_safe and new lampp installation

Postby maind_free » 06. October 2007 19:12

Hi!!

I've installed lampp and ... as lots of us, had the same problem that the mysql service is not running properly.

I've followed most of the topic regarding editind my.cnf, php.ini, but still not working properly.

By the localnost phpmyadmin I receive the #2002 error (The server is not responding (or the local MySQL server's socket is not correctly configured)

now, when I boot the system, start the mysqld_safe daemon

root 5027 1 0 21:29 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql 5075 5027 0 21:29 ? 00:00:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 5077 5027 0 21:29 ? 00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root 6305 5734 0 21:50 pts/0 00:00:00 man mysqld_safe
root 6633 6562 0 21:56 pts/1 00:00:00 grep mysql

with wrong basedit etc.

If i kill it and use lampp startmysql these process start

root 6776 1 0 21:58 pts/1 00:00:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/mauro-fisso.pid
nobody 6809 6776 0 21:58 pts/1 00:00:00 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --user=nobody --pid-file=/opt/lampp/var/mysql/mauro-fisso.pid --skip-external-locking --port=0 --socket=/opt/lampp/var/mysql/mysql.sock
root 6838 6562 0 21:59 pts/1 00:00:00 grep mysql

that seams correct but still not reckoned by apache

NOw, what can I do?
1)how to change the option to mysqld_safe first
2)how to let mysql works?

any help will appreciate!!
mauro
maind_free
 
Posts: 2
Joined: 06. October 2007 18:45
Location: Italy

Postby Wiedmann » 06. October 2007 19:35

root 6776 1 0 21:58 pts/1 00:00:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/mauro-fisso.pid

AFAIK the XAMPP way is:
/opt/lampp/lampp startmysql

http://www.apachefriends.org/en/xampp-linux.html#382
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maind_free » 07. October 2007 11:49

Thanks wiedmann,

I knew the command how to run mysql, but I was asking for a solution regarding why mysql was not working properly.

I've reinstalled lampp and seams getting better but still mysql status is shown as no active at the status page under localhost even if I could change the accessibility of mysql from the network (don't know if this can help anybody)

Now with ps -ef | grep mysql I receive these infos
root 5590 1 0 14:28 pts/0 00:00:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/mauro-fisso.pid
nobody 5623 5590 0 14:28 pts/0 00:00:00 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --user=nobody --pid-file=/opt/lampp/var/mysql/mauro-fisso.pid --skip-external-locking --port=0 --socket=/opt/lampp/var/mysql/mysql.sock
root 6450 5527 0 14:47 pts/0 00:00:00 grep mysql


how can I activate mysql for apache?
maybe I have to load a module?!
thanks
mauro
maind_free
 
Posts: 2
Joined: 06. October 2007 18:45
Location: Italy


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests