Two troubles on Linux Ubuntu 7.04

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Two troubles on Linux Ubuntu 7.04

Postby durbatuluk » 19. September 2007 13:36

Hi i have two problems...
The first told this: SQL Error: Host 'localhost' is not allowed to connect to this MySQL server ....
And second How can i add xampp start like every reset automatically? It means when i quit and turn on my ubuntu lampp starts automatically too? Thx for resolving these problems...
durbatuluk
 
Posts: 10
Joined: 15. February 2007 10:07

Re: Two troubles on Linux Ubuntu 7.04

Postby jauhari » 24. September 2007 05:16

durbatuluk wrote:Hi i have two problems...
The first told this: SQL Error: Host 'localhost' is not allowed to connect to this MySQL server ....
And second How can i add xampp start like every reset automatically? It means when i quit and turn on my ubuntu lampp starts automatically too? Thx for resolving these problems...


Hi, to started automatically, you can add this command

Code: Select all
/opt/lampp/lampp start


on your RC.LOCAL or add on your session
System > Preferences > Session and add new session with that command.

And about your fist problem, your just need to add some user on your MySQL server.
jauhari
 
Posts: 6
Joined: 19. December 2005 16:19

Postby skuipers » 24. September 2007 10:03

See also the FAQ
skuipers
 
Posts: 99
Joined: 21. January 2005 16:27
Location: The Netherlands

Postby slowyaroll » 09. October 2007 15:56

You probably should have listed these two problems separately.

However, I can most certainly help you with the latter.

True, to get XAMPP to start automatically, you can read the FAQ. The specific item you want to look at is http://www.apachefriends.org/en/faq-xampp-linux.html#fsl

If you're still new to Linux or Ubuntu, you should know that by default, Debian based distros start in Run Level 2

You'll want to issue the follow commands
Code: Select all
sudo -i

You'll be prompted to enter your password, do so
Code: Select all
cd /etc/rc2.d/
ln -s /opt/lampp/lampp S99lampp
ln -s /opt/lampp/lampp K01lampp


To exit from being the root user, use the following
Code: Select all
exit

You should now be returned to your regular user prompt.
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests