Using sendmail to send email?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Using sendmail to send email?

Postby vincentrich » 14. September 2007 15:12

I have installed sendmail on my Ubuntu Server machine.

Edit php.ini:

Code: Select all
; For Win32 only.
;sendmail_from = me@localhost.com

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = /usr/sbin/sendmail -t -i


Then I restarted my XAMPP. I tried to send email with a PHP mail script but I don't receive any emails. Is there anything else I should edit?

Here's the /var/log/mail.log file contents:

Code: Select all
Sep 14 11:52:42 ubuntu-server sendmail[7413]: My unqualified host name (ubuntu-server) unknown; sleeping for retry
Sep 14 11:53:42 ubuntu-server sendmail[7413]: unable to qualify my own domain name (ubuntu-server) -- using short name
Sep 14 11:53:42 ubuntu-server sendmail[7413]: gethostbyaddr(192.168.0.6) failed: 1
Sep 14 11:58:31 ubuntu-server sendmail[7418]: My unqualified host name (ubuntu-server) unknown; sleeping for retry
Sep 14 11:59:31 ubuntu-server sendmail[7418]: unable to qualify my own domain name (ubuntu-server) -- using short name
Sep 14 11:59:31 ubuntu-server sendmail[7418]: l8E3xVHi007418: from=nobody, size=123, class=0, nrcpts=1, msgid=<200709140359.l8E3xVHi007418@ubuntu-server>, relay=nobody@localhost
Sep 14 11:59:31 ubuntu-server sm-mta[7423]: l8E3xVpO007423: from=<nobody@ubuntu-server>, size=344, class=0, nrcpts=1, msgid=<200709140359.l8E3xVHi007418@ubuntu-server>, proto=ESMTP, daemon=MSP-v4, relay=localhost [127.0.0.1]
Sep 14 11:59:31 ubuntu-server sendmail[7418]: l8E3xVHi007418: to=myemail@whatever.com, ctladdr=nobody (65534/65534), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30123, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l8E3xVpO007423 Message accepted for delivery)
Sep 14 11:59:33 ubuntu-server sm-mta[7425]: STARTTLS=client, relay=whatever.com., version=TLSv1/SSLv3, verify=FAIL, cipher=AES256-SHA, bits=256/256
Sep 14 11:59:34 ubuntu-server sm-mta[7425]: l8E3xVpO007423: to=<myemail@whatever.com>, ctladdr=<nobody@ubuntu-server> (65534/65534), delay=00:00:03, xdelay=00:00:03, mailer=esmtp, pri=120344, relay=whatever.com. [74.200.79.210], dsn=5.1.1, stat=User unknown
Sep 14 11:59:35 ubuntu-server sm-mta[7425]: l8E3xVpO007423: l8E3xZpO007425: DSN: User unknown
Sep 14 11:59:35 ubuntu-server sm-mta[7425]: l8E3xZpO007425: to=<nobody@ubuntu-server>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30000, dsn=2.0.0, stat=Sent
Sep 14 12:00:01 ubuntu-server sm-msp-queue[7444]: My unqualified host name (ubuntu-server) unknown; sleeping for retry
Sep 14 12:01:01 ubuntu-server sm-msp-queue[7444]: unable to qualify my own domain name (ubuntu-server) -- using short name


I am trying to send an email to myemail@whatever.com. I am getting errors like unable to qualify my own domain name (ubuntu-server) and DSN: User unknown.

Could anyone help me out? This is my first time using sendmail for Linux. I have successfully configured sendmail for Windows.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby Wiedmann » 14. September 2007 15:38

I have installed sendmail on my Ubuntu Server machine.

You can send a mail via sendmail from the shell? This is the first thing you should verify.

The Ubuntu support or a Ubuntu user forum is the best place for this topic (installing and configuration of your sendmail/MTA).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby slowyaroll » 09. October 2007 15:33

If I remember correctly, Ubuntu uses PostFix as the default MTA. Did you install sendmail?
I wondered why the frisbee got bigger and bigger. . .then it hit me
slowyaroll
 
Posts: 20
Joined: 11. April 2007 07:23
Location: Atlanta, Georgia [US]


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests

cron