XAMPP on MEPIS can't see php tags

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP on MEPIS can't see php tags

Postby firemaker » 07. August 2007 12:39

I have Mepislite installed. Seems to be working fine. I also installed XAMPP. That installed and started just fine. The status shows php and mysql activated. I did the security fixes. I ran some of their demos. Thay woked okay.

I put a little html and php script in my own user public_html directory. Then I went to another computer on my home network. Using IE, I surfed the little script. It came back with a page built from just the html code. The php tags were ignored.

Any ideas about what's wrong? It's like apache is not passing the script to php. But I can't believe XAMPP would set it up that way. They didn't say anything about the need to configure apache.

Thank you.

PS: I didn't install libapache2-mod-php5. Could that be the problem?
Posts: 2
Joined: 07. August 2007 12:33

Postby Dave_L » 07. August 2007 19:17

I'm using XAMPP 1.6.2 on MEPIS 6.0, and don't have that issue, although I haven't tried browsing it from a separate computer.

I don't have libapache2-mod-php5 installed. As far as I know, XAMPP is self-contained.

Does the file with the PHP tags have the extension .php?

And are you using the full tags within the file, .e.g.

<?php echo "hello" ?>
User avatar
Posts: 212
Joined: 23. October 2004 00:43

Postby firemaker » 07. August 2007 21:29

It does have the .php extension. Yes, I'm using the full tags.
Posts: 2
Joined: 07. August 2007 12:33

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests