mysql version conflict

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mysql version conflict

Postby genarator » 18. July 2007 01:56

Hi guys, somehow mysql 5 is not suporting a database with more than 255 fields, but apparently mysql 4 does, so can you tell me wich version of xampp comes with it?, I really wouldn't like to try configure mysql 4 with the last version of xampp, better off if it comes configured already....
genarator
 
Posts: 2
Joined: 18. July 2007 01:50

Postby Wiedmann » 18. July 2007 02:30

somehow mysql 5 is not suporting a database with more than 255 fields,

That's wrong:
- With MyISAM you can have 3398 columns.
- With InnoDB you can have 1000 columns.

Maybe your column definition is to long (>64K).

(BTW: You mean columns, not fields?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Uh?

Postby genarator » 19. July 2007 18:16

columns and fields are the same, they differ from rows...
But I didn't consider the storage engines
genarator
 
Posts: 2
Joined: 18. July 2007 01:50


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests