Error 1! Couldn't start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 1! Couldn't start Apache!

Postby kthxbai2u » 02. June 2007 05:27

Code: Select all
WebServ lampp # ./lampp start
Starting XAMPP for Linux 1.6...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.
WebServ lampp #

^^ waht i get when i try to start xampp :S dont know whats wrong... Im runing saybayon linux, and the httpd.conf looks fine. all of it is installed to /opt/lampp. Why didnt you just include a list of errors and their meanings? rather than waiting untill someone asks... and then if that post gets buried, someone will guarenteed ask again and again.... At least put them on the site... although a copy in the distribution would be nice :P

Oh, one other thing, you might want to change the top to read "xampp forum" or "apache friends forum" or something similair... This isnt apache, this is xampp. a combination of others software. Use your name :P And now that I remember, the screenshot you have on the site is crap. Its showing off your PHP page. It doesnt show off xampp... xampp itself is invisible, runs in background. You could keep that screenshot and get a screenshot of the xampp control panel for windows... Maybe a screenshot of filezilla as well.
kthxbai2u
 
Posts: 9
Joined: 02. June 2007 05:16

Postby kthxbai2u » 02. June 2007 05:33

Code: Select all
Good question :) This error can exist for multiple reasons. Apache spits out this error under several circumstances. To find the exact reason we have some exploring to do:

tail -2 /opt/lampp/logs/error_log

If you now see "Invalid argument: Could not set permissions on ssl_mutex" or "Invalid argument: Unable to create scoreboard" please take a look at answers below. If you see another error message please email it to me. Maybe we can solve the problem together. My email address is oswald@apachefriends.org.
*

thats what i found in the docs, and this is what i get from tail:
Code: Select all
WebServ lampp # tail -2 /opt/lampp/logs/error_log
[Sat Jun 02 00:25:34 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sat Jun 02 00:25:35 2007] [notice] Apache/2.2.4 (Unix) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d PHP/5.2.1 mod_apreq2-20051231/2.5.7 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
WebServ lampp #


I presume i have to set my machine name to localhost?? I dont want to do that.... Whats the fix for that?
kthxbai2u
 
Posts: 9
Joined: 02. June 2007 05:16

Postby Wiedmann » 02. June 2007 05:46

Im runing saybayon linux

x86 or x86-64 Edition?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kthxbai2u » 02. June 2007 05:56

i believe its x86.... does it matter? there is only one xampp for linux distribution...
kthxbai2u
 
Posts: 9
Joined: 02. June 2007 05:16

Postby Wiedmann » 02. June 2007 06:04

there is only one xampp for linux distribution...

Correct, XAMPP is compiled for 32bit. So, if you have a 64bit system, you must install the 32bit compatibility libs from your os.

BTW:
tail -2 /opt/lampp/logs/error_log

There must also be a "apachestart_log" somewhere...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kthxbai2u » 02. June 2007 10:16

Ok. So how do I know for sure its 64 bit and not 32? There any commands to type in console? And how would i go about installing the 32 bit "libs" ? There is no apachestart_log . ls of logs folder returns the following after starting lampp:

wait.... nevermind. I was going to show you the ls of the logs directory after starting lampp but i stopped it and started it again (like i have numerous times) and for some reason now its loading up without any errors.... Thank you for your time :D [/code]
kthxbai2u
 
Posts: 9
Joined: 02. June 2007 05:16


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests