Disable XAMPP authnetication password for web address

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Disable XAMPP authnetication password for web address

Postby jza » 01. June 2007 18:56

I ran the Xampp security and I guess I went yes beside knowing what it was asking me. :sorry:

However I need to get back into my site, but before I also want to learn.

So I ran /opt/lampp security in order to secure the server.

The next step was to put a password on my XAMPP site (my mistake)

Now I want to log in my site and it prompt me for a password, I put the user (root) and my password and it doesn't let me login.

What should I put as an user?
How can I disable the authentication? (I want this to be public site)
jza
 
Posts: 4
Joined: 01. June 2007 18:52
Location: Villahermosa, Tabasco

Postby Dave_L » 02. June 2007 00:03

I think the default username is "lampp".

You can always figure that out by looking for the .htaccess file(s), and seeing which file is referenced by the AuthUserFile directive. For XAMPP 1.6.1, it's /opt/lampp/lib/xampp.users. The entries in that file are of the form:
USERNAME:ENCRYPTED-PASSWORD

You could disable the password protection by removing the .htaccess file(s). But if you want the site to be public, you probably still want the XAMPP control panel to be password-protected.

You can also change the usernames and password without using XAMPP by using the Apache command /opt/lampp/bin/htpasswd. Type the command without any options or parameters to view usage info.
User avatar
Dave_L
 
Posts: 212
Joined: 23. October 2004 00:43


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests