Mod mono and xampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Mod mono and xampp

Postby miedeth » 06. April 2007 04:13

Ok, long story short, I'm a windows programmer by trade, but at home I run a linux webserver. In this case I'm using Ubuntu and it's been running just fine. I recently installed mod_mono using the apt-get, it of course wants to put it with apache2 rather then xampp.

Simply adding the line

LoadModule mono_module /usr/lib/apache2/modules/mod_mono.so also creating a copy of the mod_mono.so and puting it in xampp's module and just using /modules/mod_mono.so gives me the same error when I try to restart lampp.

httpd: Syntax error on line 54 of /opt/lampp/etc/httpd.conf: Cannot load /usr/lib/apache2/modules/mod_mono.so into the server: /usr/lib/apache2/modules/mod_mono.so: undefined symbol: apr_sockaddr_port_get

What can I do to get mod_mono to work with xampp, or if it won't work, what else can I use so I can move my asp.net pages to my server here at the house to save the hosting fees?
miedeth
 
Posts: 2
Joined: 06. April 2007 03:56

Postby Wiedmann » 06. April 2007 10:35

You must compile mod_mono by yourself if you want use it in XAMPP.

If you want use "apt-get", you must use "apt-get" for the Apache too.
--> no XAMPP
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby miedeth » 06. April 2007 16:44

Ok, thanks. Guess I have a lot of work ahead of me then.
miedeth
 
Posts: 2
Joined: 06. April 2007 03:56


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests