XAMPP is not Starting !!!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP is not Starting !!!

Postby HexenBlack » 02. April 2007 06:58

Hello all ,

I'm having a really weird problem !!

I installed the Xampp on a linux 4 box, everything was working great, the ip was a static private IP according to the LAN i was working on, and everything seemed to be ok !

Now a few days ago, the guys working at the server changed it IP address, also they added an IP address to the other ethernet interface, and even though they specified it as a trusted device, XAMPP will not start, and neither will it shutdown, no error messages no nothing, just blanks, I was planning on uploading a snapshot image but it seems its forbidden in this forum, so this is exactly what is displayed on the terminal and the commands I execute:
Code: Select all
shell>/opt/lampp/lampp start
shell>/opt/lampp/lampp stop

After i start it, it should give some indication as to what it is doing right? its not giviving me anything, I executed the code block above at the tetrminal window exactly as it is, and it didnt give me anything, no output no feedback no nothing.
What am I missing here, I know this is not supposed to happen, because if there were any errors I should be able to get some feedback from the XAMPP shell interpreter right? Please point in the right direction, I'm working on the server remotely and I'm running out of time.
Posts: 1
Joined: 02. April 2007 06:52

Re XAMPP is not Starting !!!

Postby Walta » 04. April 2007 15:13

Are you shure that xampp is not starting?
I had the same problem on my brandnew linux-machine.
It takes a lot of time to stop/start the xampp. I controlled it
via ps ax.

Another problem is that the routine rarely shows errormsg.
Please check your *access.log *error.log in the directory
you choose while configuring apache.

HTH Walta
Posts: 1
Joined: 04. April 2007 15:06

IP change

Postby rajah9 » 18. April 2007 20:57

I had a similar problem when my static IP changed.

When I looked at /opt/lampp/logs/apachestart.log , I saw that there was trouble binding. I changed httpd.conf so that it had a simple "Listen 80" and I was able to start Apache.

From my Fedora box I tried to ping the new IP address, but it responded with the old address.

I changed the file etc/sysconfig/network-scripts/ifcg-eth0. Changed the old IPADDR= and GATEWAY= to the new values.

Then I stopped Apache, recycled the ethernet card with ifdown eth0 / ifup eth0, and restarted Apache.

Everything worked well after then. I corrected the Listen in httpd.conf to the full octet on port 80.
Posts: 1
Joined: 09. March 2006 22:50

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests