eaccelerator could not lock

Problems with the Linux version of XAMPP, questions, comments, and anything related.

eaccelerator could not lock

Postby xychen » 20. March 2007 00:10

I am using my xampp 1.5.5a and 1.6. I enabled the eaccelerator and always get
eAccelerator: Could not lock!
eAccelerator: Could not release lock!
in apache error_log.

I am using CentOS.

I get 2G of error_log of this message. I have to send the error_log to /dev/null. But somehow, the caching mechanism works for sure. My site is much faster.

Any body has the same problem or solution?
xychen
 
Posts: 1
Joined: 20. March 2007 00:05

Postby muychingon » 25. March 2007 01:08

Hey there. I see the same thing in my logs. I found a quick bandaid for the logs growing out of control but I can't find out how to actually fix the problem.

I'm also looking for more information on this. The error log doesnt tell me much in relation as to why its not locked or why it could not release the lock. This is what I see... thousdands of lines...

eAccelerator: Could not release lock!
eAccelerator: Could not lock!

I'd like to just disable it for now, but I can't even figure out how to do that. I do not have access to the webgui so I'd like to disable it via the command line.

running FC4.
muychingon
 
Posts: 1
Joined: 03. October 2006 16:39

Postby ahmershuja » 18. June 2007 05:08

I've the same problem with ...

eAccelerator: Could not release lock!
eAccelerator: Could not lock!

I'm using Fedora 5 with XAMPP 1.6 with php5
User avatar
ahmershuja
 
Posts: 6
Joined: 14. April 2007 23:17
Location: CANADA

Postby yellow » 22. July 2007 19:11

Still no solution yet? I'm having exactly the same problem too.
yellow
 
Posts: 8
Joined: 23. December 2004 06:04

Postby yellow » 01. August 2007 00:01

Try this guys, seem to work for me:
chmod 0777 /opt/lampp/tmp/eaccelerator
yellow
 
Posts: 8
Joined: 23. December 2004 06:04

Postby skuipers » 01. August 2007 07:26

Do you really need 0777? Isn't 0755 sufficient enough? I always try to avoid to give write access to everybody.

Simon
skuipers
 
Posts: 99
Joined: 21. January 2005 16:27
Location: The Netherlands

Postby yellow » 01. August 2007 09:42

Then just try 755, if that does not work then you can try something else ^^.
yellow
 
Posts: 8
Joined: 23. December 2004 06:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests