Proper build environment for XAMPP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Proper build environment for XAMPP

Postby gdeckler » 08. February 2007 15:43

OK, this is related to the mod_jk issue in trying to compile it for XAMPP (1.5.3a) with Apache 2.2.x. I have the XAMPP devel package and issue the configure command:

./configure --with-apxs2=/opt/lampp/bin/apxs --with-apache=/usr/local/src/lampp/

This works, then "make" gives:

...
gcc -I/usr/local/src/lampp//include -I/usr/local/src/lampp//srclib/apr/include -I/usr/local/src/lampp//os/unix -I/usr/local/src/lampp//srclib/apr-util/include -g -O2 -g -O2 -I /include -I /include/ -c jk_status.c -o jk_status.o >/dev/null 2>&1
make[1]: Leaving directory `/home/gdeckler/tomcat-connectors-1.2.20-src/native/common'
Making all in apache-2.0
make[1]: Entering directory `/home/gdeckler/tomcat-connectors-1.2.20-src/native/apache-2.0'
/bin/sh ../libtool --mode=compile gcc -I/usr/local/src/lampp//include -I/usr/local/src/lampp//srclib/apr/include -I/usr/local/src/lampp//os/unix -I/usr/local/src/lampp//srclib/apr-util/include -g -O2 -DUSE_APACHE_MD5 -I ../common -I /include -I /include/ -g -O2 -c mod_jk.c -o mod_jk.lo
mkdir .libs
gcc -I/usr/local/src/lampp//include -I/usr/local/src/lampp//srclib/apr/include -I/usr/local/src/lampp//os/unix -I/usr/local/src/lampp//srclib/apr-util/include -g -O2 -DUSE_APACHE_MD5 -I ../common -I /include -I /include/ -g -O2 -c mod_jk.c -fPIC -DPIC -o .libs/mod_jk.o
In file included from /usr/local/src/lampp//include/ap_config.h:25,
from mod_jk.c:29:
/usr/local/src/lampp//include/apr.h:270: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'apr_off_t'
In file included from mod_jk.c:32:
/usr/local/src/lampp//include/apr_file_info.h:204: error: expected specifier-qualifier-list before 'apr_off_t'
In file included from mod_jk.c:33:
/usr/local/src/lampp//include/apr_file_io.h:548: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/local/src/lampp//include/apr_file_io.h:740: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /usr/local/src/lampp//include/httpd.h:53,
from mod_jk.c:34:
...

I checked where things start to go wrong:
/usr/local/src/lampp//include/apr.h:270: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'apr_off_t'

and line 270 of apr.h is the typdef off64_t line below:

typedef size_t apr_size_t;
typedef ssize_t apr_ssize_t;
typedef off64_t apr_off_t;
typedef socklen_t apr_socklen_t;

Which doesn't look particularly heinous.

Here is my environment

RedHat ES4 OS
i386 environment

My build environment:

· Download: glibc-kernheaders-3.0-5.2.i386.rpm
· Download: glibc-common-2.5.90-16.i386.rpm
· Download: glibc-2.5.90-16.i386.rpm
· Download: glibc-headers-2.5.90-16.i386.rpm
· Download: binutils-2.17.50.0.9-1.i386.rpm
· Download: glibc-devel-2.5.90-16.i386.rpm
· Download: libgomp-4.1.1-55.i386.rpm
· Download: libgcc-4.1.1-55.i386.rpm
· Download: cpp-4.1.1-55.i386.rpm
· Download: gcc-4.1.1-55.i386.rpm
· Download: libstdc++-4.1.1-55.i386.rpm
· Download: libstdc++-devel-4.1.1-55.i386.rpm
· Download: gcc-c++-4.1.1-55.i386.rpm
· Download: libpng-1.2.8-2.2.1.i386.rpm
· Download: cairo-1.3.12-1.fc7.i386.rpm
· Download: glib2-2.12.9-3.fc7.i386.rpm
· Download: libthai-0.1.7-5.fc7.i386.rpm
· Download: filesystem-2.4.1-1.i386.rpm
· Download: xorg-x11-filesystem-7.1-2.fc6.noarch.rpm
· Download: libXau-1.0.3-1.fc7.i386.rpm
· Download: libXdmcp-1.0.2-2.fc7.i386.rpm
· Download: libX11-1.0.3-7.fc7.i386.rpm
· Download: libXext-1.0.1-2.1.i386.rpm
· Download: libXft-2.1.8.2-3.2.i386.rpm
· Download: libXrender-0.9.2-1.fc7.i386.rpm
· Download: pango-1.15.5-1.fc7.i386.rpm
· Download: libgcj-4.1.1-55.i386.rpm
· Download: libobjc-4.1.1-55.i386.rpm
· Download: gcc-objc-4.1.1-55.i386.rpm

· rpm -ivh glibc-kernheaders-3.0-5.2.i386.rpm
· rpm –Fvh glibc*
· rpm -ivh glibc-headers-2.5.90-16.i386.rpm
· rpm -Fvh binutils-2.17.50.0.9-1.i386.rpm
· rpm -ivh glibc-devel-2.5.90-16.i386.rpm
· rpm -ivh libgomp-4.1.1-55.i386.rpm
· rpm -Fvh libgcc-4.1.1-55.i386.rpm
· rpm -ivh cpp-4.1.1-55.i386.rpm
· rpm -ivh gcc-4.1.1-55.i386.rpm
· rpm -Fvh libstdc++-4.1.1-55.i386.rpm
· rpm -ivh libstdc++-devel-4.1.1-55.i386.rpm
· rpm -ivh gcc-c++-4.1.1-55.i386.rpm
· rpm -Fvh libpng-1.2.8-2.2.1.i386.rpm
· rpm -ivh --nodeps cairo-1.3.12-1.fc7.i386.rpm
· rpm -Fvh glib2-2.12.9-3.fc7.i386.rpm
· rpm -ivh libthai-0.1.7-5.fc7.i386.rpm
· rpm -Fvh filesystem-2.4.1-1.i386.rpm
· rpm -ivh xorg-x11-filesystem-7.1-2.fc6.noarch.rpm
· rpm -ivh libXau-1.0.3-1.fc7.i386.rpm
· rpm -ivh libXdmcp-1.0.2-2.fc7.i386.rpm
· rpm -ivh libX11-1.0.3-7.fc7.i386.rpm
· rpm -ivh libXext-1.0.1-2.1.i386.rpm
· rpm -ivh libXft-2.1.8.2-3.2.i386.rpm
· rpm -ivh libXrender-0.9.2-1.fc7.i386.rpm
· rpm -Fvh pango-1.15.5-1.fc7.i386.rpm
· rpm -Fvh libgcj-4.1.1-55.i386.rpm
· rpm -Fvh libobjc-4.1.1-55.i386.rpm
· rpm -ivh gcc-objc-4.1.1-55.i386.rpm

Any suggestions as to a build environment that will work for this? I can't fathom why it would just suddenly bail on that particular line of code. Do I need some additional "configure" flags? Should I be pointing configure to a different location? What gives?
gdeckler
 
Posts: 6
Joined: 06. February 2007 19:37

Postby Wiedmann » 08. February 2007 16:06

IMHO mod_jk is not for Apache 2.2.x (only for Apache 2.0.x).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gdeckler » 08. February 2007 16:33

OK, but do you agree that the Tomcat Connectors documentation states that mod_jk is supposed to work for Apache 2.2 but that you need a version compiled for Apache 2.2?

From: http://tomcat.apache.org/connectors-doc ... s/faq.html

Does it work for Apache 2.2?
mod_jk works well with Apache 2.2. You need a binary module compiled for version 2.2 of the Apache web server. A binary compiled for version 2.0 will not work.

Important parts of the functionality of mod_jk have been reimplemented as Apache httpd modules mod_proxy_ajp and mod_proxy_balancer. These are part of the standard distributoin of Apache 2.2. The new modules do not contain all features of mod_jk, but you get them automatically with every Apache 2.2.


Do you know the latest XAMPP version still has Apache 2.0 in it?

Can you point me to any good Tomcat Connector forums?

Thanks.
gdeckler
 
Posts: 6
Joined: 06. February 2007 19:37

Postby Wiedmann » 08. February 2007 16:43

Do you know the latest XAMPP version still has Apache 2.0 in it?

XAMPP for Linux 1.5
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gdeckler » 08. February 2007 21:11

Just to close the book on this, I've given up on this approach and decided to pursue mod_proxy_ajp instead. Thanks for the assistance. I also did try the mod_jk rpm package with various different flags and always got the same "garbled .so" response. So, that's not the way to go either.
gdeckler
 
Posts: 6
Joined: 06. February 2007 19:37


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests