mySQL - can not import database

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mySQL - can not import database

Postby RikR » 24. January 2007 05:48

I have a small database that is running in mySQL 4.x on a hosting server.

When I attempt to create a database and import the text file backup into mySQL in my xampp installation, it will not import.

The xampp mySQL is 5.0.27. I get this error:

No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16.

Should the mySQL 5 import a mySQL 4 database?

I have never had a problem doing this on the mySQL at my host service.
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Postby Wiedmann » 24. January 2007 06:08

See FAQ 1.16.

You read this?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RikR » 25. January 2007 00:02

Yes, but it does not seem to apply to my situation. My file is only 86k.
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Postby Wiedmann » 25. January 2007 00:30

Ok.

Try importing your backup in the shell (with mysql.exe).

BTW:
text file backup

This file is a correct and complete (with all data) MySQL dump?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RikR » 25. January 2007 02:18

On my XP PC I run a package called EasyPHP, sort of like xampp.

I just imported the same file into mySQL using phpmyadmin with no problem.

But, I hope to be able to move my work over to my Mandriva Linux PC and use xampp package.

I started out trying to do a LAMP set up on the Linux box by installing the individual apps, but couldn't ever seem to get things configured correctly.

XAMPP looks like the solution for me, but...
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Postby RikR » 03. February 2007 23:57

I have tried other sql back up files and none will import. All give the same error.
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Postby Wiedmann » 04. February 2007 00:30

Wiedmann wrote:Try importing your backup in the shell (with mysql.exe).

You have done this?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RikR » 04. February 2007 02:51

I have tried, but can not figure out how, so do not know yet if it will work.
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Postby Wiedmann » 04. February 2007 03:01

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RikR » 06. February 2007 00:16

Sorry, that page didn't help me much.

For now, I am giving up. Xampp really looks good, but for now, I'll have to be content with using easyPHP on my Windows PC.

Thanks for trying to help me. I just really don't want to get as deep into it as is apparently needed to get this to work.

I regret I don't have more time to learn all the things you need to know to make Linux boxes productive for me. I really believe there is a lot of potential benefit, just have to decide how I want to spend my time.
RikR
 
Posts: 6
Joined: 24. January 2007 05:23

Solution

Postby pieterb » 13. May 2007 11:28

Before importing an exported database you first have to create an empty one with the same name. You can do that in phpmyadmin or the shell.
pieterb
 
Posts: 1
Joined: 13. May 2007 11:23

Postby gizmobay » 05. June 2007 05:02

I'm having the same problem as well. I have a small database I'm trying to import and I get the same error. I tried to create a database with the same name as the sql file and I still got the same error. Anyone know how to fix this?
gizmobay
 
Posts: 1
Joined: 05. June 2007 04:40

Postby bandelier » 01. November 2007 21:02

I'm getting this same error when trying to import my db's & tables - none are over the size limits set in php.ini, yet it won't let me bring them in. I use OX X 10.5 (leopard) - and finally got phpmyadmin to work with XAMPP on this machine - but now can't get it to bring my goodies in via the import tool. I verified all of my settings in the php.ini file - all are good. Still not working.
bandelier
bandelier
 
Posts: 5
Joined: 30. October 2007 19:58
Location: denver, co

Re: Solution

Postby bandelier » 02. November 2007 02:11

pieterb wrote:Before importing an exported database you first have to create an empty one with the same name. You can do that in phpmyadmin or the shell.


This doesn't work either. Did that. I'm thinking it might be an issue with the SSL?
bandelier
bandelier
 
Posts: 5
Joined: 30. October 2007 19:58
Location: denver, co

Postby ray429 » 04. November 2007 08:30

I am not sure whether it is due to the upload limit of php since phpmyadmin runs from php. However, even I changed the php upload limit in the php.ini file to 15M which is more than the schema I have got, it still gives me the same error.
ray429
 
Posts: 9
Joined: 02. November 2007 02:18

Next

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests