eaccelerator and XAMPP 1.5.5a

Problems with the Linux version of XAMPP, questions, comments, and anything related.

eaccelerator and XAMPP 1.5.5a

Postby maxhb » 18. January 2007 15:32

Hello!
I have updated 3 different webservers to XAMPP 1.5.5a. Apparently everything was o.k. but the I recognized that eaccelerator (I need this extension for encoding / decoding) does not work correctly on 2 of the 3 servers. PHP4 is enabled.

When starting XAMPP the following warning is shown:

PHP Warning: [eAccelerator] this build of "eAccelerator" was compiled fpr version 4.4.0 Rebuild it for your PHP version (4.4.4) or download precompiled binaries.

The working system is a Knoppix Linux, both corrupted servers are based on SUSE Linux

Comparing the phpinfo() opuput of all 3 servers alle relevant settings seem to match:
PHP API 20020918
PHP Extension 20020429
Zend Extension 20050606
extension_dir /opt/lampp/lib/php/extensions/no-debug-non-zts-20020429


Analyzing the eaccelerator.so library generates the following output:

Knoppix:
#ldd eaccelerator.so
libc.so.6 => /lib/libc.so.6 (0x4002e00)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


SUSE Server1:
#ldd eaccelerator.so
libc.so.6 => /lib/tls/libc.so.6 (0xb7e9b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


SUSE Server2:
#ldd eaccelerator.so
libc.so.6 => /lib/libc.so.6 (0x40029000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


Seems like every server uses different libraries...

The strangest thing is that sometimes(!) I manage to start XAMPP with eaccelerator enabled even on the SUSE servers (error warning is shown but does not seem to matter...).


Does anyone have an idea what is going wrong? Do you need more information for analysis?

CU
maxhb
User avatar
maxhb
 
Posts: 17
Joined: 18. January 2007 15:08
Location: Bremen

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests