MySQL root@localhost password

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL root@localhost password

Postby theillien » 23. December 2006 17:00

I'm trying to set the password for 'root'@'localhost'. I execute the query successfully but when I try to go back to the phpMyAdmin homepage I get "Cannot connect: invalid setting"

The only way to fix it is to log into MySQL via the command line and remove the password.

Why is this happening? Why can't I set the password? When I am able to open the homepage it says User: root@localhost. If I'm accessing the page as root@localhost, shouldn't it be asking me for my password or something?
theillien
 
Posts: 3
Joined: 23. December 2006 16:55

Similar question - mysql root passwd change

Postby csinclair » 03. January 2007 16:08

I as well was wondering where the English documentation was for security settings after install, how do I change mysql's root user password, and disable the blank password user accounts as well.
I'm using Slackware 11.0 and aside from those major security concerns, all went well with the install.
csinclair
 
Posts: 3
Joined: 03. January 2007 07:12
Location: Canada eh!

Postby theillien » 03. January 2007 16:24

If I recall correctly, simply running /opt/lampp/lampp security will put you throught the lockdown script. However, there are only a few steps such as requiring a username/password just to access the folder/site, an FTP password, and I think one other. But it wasn't a MySQL password, that's for certain.
theillien
 
Posts: 3
Joined: 23. December 2006 16:55

/opt/lampp/lampp security

Postby csinclair » 05. January 2007 22:14

Yes,
You are right, running /opt/lampp/lampp security while xampp is running is required, I did it the first time while xampp was not running and it didn't work properly.

Thanks,
Craig
csinclair
 
Posts: 3
Joined: 03. January 2007 07:12
Location: Canada eh!


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests