Apache and ProFTPd can't start..

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache and ProFTPd can't start..

Postby Zaba » 16. December 2006 09:02

Hi all, this was probably asked already,
I got problems with Apache and Proftpd
after about 1/2 year of normal work.
They can't start like

Starting XAMPP for Linux 1.5.4a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: - IPv4 getaddrinfo 'localhost' error: Name or service not known
- warning: unable to determine IP address of 'localhost'
- error: no valid servers configured
- Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.

I am sure no other process owns ports 80 and 21.
And i'm sure that ProFTPd worked nowmally all the time.

Thanks in advice..
Zaba
 
Posts: 10
Joined: 22. April 2006 16:34

Postby deepsurfer » 20. December 2006 00:22

make another start, after you see the message in console
Code: Select all
less /opt/lampp/logs/apachestart.log

here must stand whots wrong...

Post it here :idea:

greets
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Kristian Marcroft » 21. December 2006 15:23

Hi,

try this command as root:

# echo "127.0.0.1 localhost" >> /etc/hosts
(without the #)

Then try and startup XAMPP again.

Regards,
Kristian Marcroft
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Zaba » 25. December 2006 11:31

Kristian Marcroft:
No, it doesn't help. But the problem seems to be in that file cause reinstallation doesn't help either.

deepsurfer:
That log is empty.

Regards.
Zaba
 
Posts: 10
Joined: 22. April 2006 16:34

Postby deepsurfer » 25. December 2006 12:09

which linux distribution you use ??

open a console and write "ping localhost"

answer in console must look like this
Code: Select all
PING localhost (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.1 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.0 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.0 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.0 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.0 ms


(stop with ctrl & c )

look this in your linux ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Zaba » 28. December 2006 10:54

I use gentoo (and their apache sucks so i want to use lampp)

I'm getting unknown host: localhost so i'm sure it's a problem in /etc/hosts.

my /etc/hosts is the following:

# /etc/hosts: Local Host Database
#
# This file describes a number of aliases-to-address mappings for the for
# local hosts that share this file.
#
# In the presence of the domain name service or NIS, this file may not be
# consulted at all; see /etc/host.conf for the resolution order.
#

# IPv4 and IPv6 localhost aliases
127.0.0.1 localhost
127.0.0.1 localhost.localdomain localhost
::1 localhost

#
# Imaginary network.
#10.0.0.2 myname
#10.0.0.3 myfriend
#
# According to RFC 1918, you can use the following IP networks for private
# nets which will never be connected to the Internet:
#
# 10.0.0.0 - 10.255.255.255
# 172.16.0.0 - 172.31.255.255
# 192.168.0.0 - 192.168.255.255
#
# In case you want to be able to connect directly to the Internet (i.e. not
# behind a NAT, ADSL router, etc...), you need real official assigned
# numbers. Do not try to invent your own network numbers but instead get one
# from your network provider (if any) or from your regional registry (ARIN,
# APNIC, LACNIC, RIPE NCC, or AfriNIC.)
#
Zaba
 
Posts: 10
Joined: 22. April 2006 16:34

Postby Zaba » 29. December 2006 09:46

Also, i can start xampp and ping localhost when i'm disconnected from internet.
Zaba
 
Posts: 10
Joined: 22. April 2006 16:34

Postby Zaba » 30. December 2006 13:59

Also, if i start Xampp while disconnected from internet, i _still_ can't access localhost.
Zaba
 
Posts: 10
Joined: 22. April 2006 16:34

Postby Qelmark » 13. January 2007 18:39

I experienced a similar problem after upgrading/installing new programs on my Ubuntu Edgy system which installed some standard Apache files as dependeancies.

Check that you do not have another copy of Apache running somewhere on your system. If you do get rid of it as I did. Next I deleted everything in my /opt/lampp directory except the etc and htdocs directories and performed a fresh install.


Normal service was resumed.
Qelmark
 
Posts: 2
Joined: 13. January 2007 18:25


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests