problem with virtual hosts

Problems with the Linux version of XAMPP, questions, comments, and anything related.

problem with virtual hosts

Postby tbl » 10. October 2006 21:37

I have a server with SUSE 10.0, and I have just installed xampp . I have set up my virutal hosts file as I think it should be ... but I get time out at the domains I have in the virtual hosts file. I haven't made any changes in the httpd.conf file

Here's the virtual hosts file:

Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80



<VirtualHost *:80>
   DocumentRoot /opt/lampp/htdocs/xampp
   ServerName localhost:80
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /srv/www/vhosts/main
   <Directory "/srv/www/vhosts/main">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
   ServerName www.brueland.net:80
   ServerAlias brueland.net
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /srv/www/vhosts/brueland
   <Directory "/srv/www/vhosts/brueland">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
   ServerName www.brueland.info:80
   ServerAlias brueland.info
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /srv/www/vhosts/razor
   <Directory "/srv/www/vhosts/razor">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
   ServerName www.razorserver.info:80
   ServerAlias razorserver.info
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /srv/www/vhosts/overhalla
   <Directory "/srv/www/vhosts/overhalla">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
   ServerName www.overhallasiden.info:80
   ServerAlias overhallasiden.info
</VirtualHost>


Can anyone help me here?

Thanks in advance

-Tommy
tbl
 
Posts: 6
Joined: 05. August 2006 00:09

Postby Wiedmann » 10. October 2006 21:44

The vhosts (and name resolution for these domians) looks ok. The problem must be a firewall, wrong router settings or your isp.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tbl » 10. October 2006 22:26

Thanks Wiedmann.

I will check it out

-Tommy
tbl
 
Posts: 6
Joined: 05. August 2006 00:09


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests