Virtual hosts

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Virtual hosts

Postby Nec_pluribus_impar » 09. August 2006 21:25

When I active the virtual hosts, I have the message :

The requested URL /xampp/ was not found on this server.

Where is the problem ?
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby Wiedmann » 09. August 2006 21:46

There is no subdirectory "xampp" inside the DocumentRoot of that virtual host you want access.

And if you open the location "/xampp/" on this vhost with your browser (a URI like "http://localhost/xampp/"), Apache can't find a target directory for this URI.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Nec_pluribus_impar » 09. August 2006 22:04

I understand, but I wont to access my URL and the server redirect it automaticly into /xampp directory, at it send the error message
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby bubbul » 09. August 2006 22:10

remove the index.html located in the /opt/lampp/htdoc/ directory.
and you be able to use your URL and it will not ask for Xampp.

But if you need to use phpmyadmin and other tools, you will need /xampp/ in the htdoc/ directory.
bubbul
 
Posts: 4
Joined: 05. August 2006 22:53
Location: France

Postby Nec_pluribus_impar » 09. August 2006 22:51

Sorry, but I haven't index.html into /opt/lampp/htdocs folder and my DocumentRoot for my VirtualHost is in /opt/lampp/htdocs/html/myfolder.
I'll show you my httpd-vhosts.conf :

<VirtualHost palaisdesdesserts.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs
ServerName www.palaisdesdesserts.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/palaisdesdesserts.com-error_log
CustomLog logs/palaisdesdesserts.com-access_log common
</VirtualHost>

<VirtualHost gourmandises-luberon.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/gourmandises-luberon
ServerName www.gourmandises-luberon.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/gourmandises-luberon.com-error_log
CustomLog logs/gourmandises-luberon.com-access_log common
</VirtualHost>

<VirtualHost wireless-gargas.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/wireless-gargas
ServerName www.wireless-gargas.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/wireless-gargas.com-error_log
CustomLog logs/wireless-gargas.com-access_log common
</VirtualHost>

<VirtualHost www.aptapol.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/aptapol
ServerName www.aptapol.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/aptapol.com-error_log
CustomLog logs/aptapol.com-access_log common
</VirtualHost>

www.palaisdesdesserts.com is my default server into httpd.conf, every time when i wont to access to one of this serveurs I have the same error...
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby Wiedmann » 09. August 2006 22:57

When you access a DocumentRoot with "http://servername/" and you are forwarded to "http://servername/xampp/" and there is no index document in this DocumentRoot which contain such a redirect:
Then you have to clear your browser cache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Nec_pluribus_impar » 09. August 2006 23:02

What browser cache, into my client host or server ?
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby Nec_pluribus_impar » 09. August 2006 23:22

So, in my client host I have the message error in Mozilla browser and in "beurk" IE the error is (in French - is my language)
La page est introuvable

The page is untraceable in english
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby Nec_pluribus_impar » 09. August 2006 23:39

OK, I was change litelly my httpd-vhosts.conf :


NameVirtualHost palaisdesdesserts.com:80

<VirtualHost palaisdesdesserts.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs
ServerName www.palaisdesdesserts.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/palaisdesdesserts.com-error_log
CustomLog logs/palaisdesdesserts.com-access_log common
</VirtualHost>

NameVirtualHost gourmandises-luberon.com:80

<VirtualHost gourmandises-luberon.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/gourmandises-luberon
ServerName www.gourmandises-luberon.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/gourmandises-luberon.com-error_log
CustomLog logs/gourmandises-luberon.com-access_log common
</VirtualHost>

NameVirtualHost wireless-gargas.com:80

<VirtualHost wireless-gargas.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/wireless-gargas
ServerName www.wireless-gargas.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/wireless-gargas.com-error_log
CustomLog logs/wireless-gargas.com-access_log common
</VirtualHost>

NameVirtualHost aptapol.com:80

<VirtualHost www.aptapol.com:80>
ServerAdmin jestom@free.fr
DocumentRoot /opt/lampp/htdocs/html/aptapol
ServerName www.aptapol.com
# ServerAlias www.dummy-host.example.com
ErrorLog /opt/lampp/htdocs/html/aptapol.com-error_log
CustomLog logs/aptapol.com-access_log common
</VirtualHost>

and now all my VirtualHosts are going to www.
So my virtual hosts are not activated.
Nec_pluribus_impar
 
Posts: 6
Joined: 09. August 2006 21:18

Postby heavenlyevil » 21. August 2006 21:15

I was having this same problem. Your virtual hosts are being called or the URL wouldn't work.

Do you have the security features turned on? I tried everything I could think of, then eventually backed up my httpd-vhosts.conf and reinstalled, this time without turning the passwords on.

After this, I stopped having /xampp/ appended to the URLs and messing with my directory structure. Everything is working fine now.
"We're all mad here....You may have noticed I'm not all there myself." -- Cheshire Cat
User avatar
heavenlyevil
 
Posts: 1
Joined: 21. August 2006 21:08
Location: Waterloo,ON


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests