InnoDB problem (not the usual)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

InnoDB problem (not the usual)

Postby RAJ » 04. August 2006 09:04

InnoDB tables are not available. Have wiped the partition and re-installed PCLinuxOS & XAMPP and made no other changes, except to uncomment the 'skip-innodb' line in /opt/lampp/etc/my.cnf. Same distro on other PC's gives InnoDB option as soon as I comment out the 'skip-innodb' line and re-start MySQL. Have tried placing a copy of my.cnf in /etc, but to no effect. Is there any other known reason for InnoDB tables to be unavailable? Something to do with the host machine?
RAJ
 
Posts: 8
Joined: 22. June 2006 09:22

Postby RAJ » 04. August 2006 10:13

If it's any help, I just noticed the contents of the localhost.err file in /opt/lampp/var/mysql:

060804 10:02:16 mysqld started
/opt/lampp/sbin/mysqld: Can't read dir of '/root/tmp/' (Errcode: 13)
/opt/lampp/sbin/mysqld: Can't create/write to file '/root/tmp/ibcpbH8n' (Errcode: 13)
060804 10:02:16 InnoDB: Error: unable to create temporary file; errno: 13
060804 10:02:16 [Note] /opt/lampp/sbin/mysqld: ready for connections.
Version: '5.0.21' socket: '/opt/lampp/var/mysql/mysql.sock' port: 3306 Source distribution

Have set /root/tmp permissions to 777 but does not help.
RAJ
 
Posts: 8
Joined: 22. June 2006 09:22

Postby RAJ » 04. August 2006 18:59

Despite the overwhelming response ;-) I've fixed it - for the benefit of anyone else having this problem, I uncommented the line:

tmpdir = /tmp/

to set the temp directory to one without a permissions problem. InnoDB tables now an option.
RAJ
 
Posts: 8
Joined: 22. June 2006 09:22


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests