openldap ssl/ldaps problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

openldap ssl/ldaps problem

Postby jrotering » 02. August 2006 15:41

I just installed XAMPP/LAMMP 1.5.3a on SuSE 10.1.

I need to use PHP scripts to access a secure ldap directory. I've used the scripts elsewhere successfully but the ldap connection isn't working with the LAMPP environment.

Script looks like this:

$server = "ldaps://xxx.xxx.org";
$ds = ldap_connect($server);
$bind = ldap_bind($ds);

The bind fails, and returns "Can't contact LDAP server (-1)"

I get the same error from the ldapsearch script in /opt/lampp/bin/:

bin/ldapsearch -H "ldaps://xxx.xxx.org" -x

returns this:

ldap_bind: Can't contact LDAP server (-1).

However when I use the SuSE-installed OpenLDAP on this system, the bind works just fine.

This tells me that the problem is with the XAMPP OpenLDAP configuration. (Correct me if you think this is wrong).

Does anyone know how I could either reconfigure the OpenLDAP installation OR somehow have XAMPP use the SuSE-provided OpenLDAP? Or any other suggestions?

Thanks,
James
jrotering
 
Posts: 1
Joined: 02. August 2006 15:23

an old ldap issue with XAMPP on linux

Postby rjsavaglio » 13. June 2007 19:35

Hello James,

Did you ever get a solution to this problem? I have the EXACT same issue, even though it is RedHat and not SuSE linux. Any advice you could provide would be a great help.

Bob
rjsavaglio
 
Posts: 1
Joined: 13. June 2007 19:26

problems with LDAPS after installaing XAMPP

Postby dum » 26. June 2007 12:39

Hello,
I just subscribed to this list and want to thank everybody for each possible support I may find here.

I used the PHP and Apache version that comes with the suSE SLES.
Becaus I did not get an upgrade and did not want to complie PHP on my own, I installed the latest version of XAMPP.
The only problem that remains after this upgrade is that my connection to on ldap server (Microsoft AD) using ldaps does not work anymore.
Does anyone has an idea ?
Installed version : xampp-linux-1.6.2
dum
 
Posts: 1
Joined: 26. June 2007 12:32

Version mismatch

Postby najones » 05. July 2007 17:53

It could be a version mismatch on client and server. This can cause problems sometimes. I'm having this issue with OS X server 10.4.10 (Ldap v3 1.7.4) and ldap client version 2.3.27-25.

Basically in my 2 years experience with it as an administrator, I've concluded that OS X server blows compared to any linux distribution used for serving these common open source packages like LAMP or ldap. Basically you can't trust a company like Apple or Microsoft who would cripple their software to create lock in.

I did not have the issue with whatever ldap version was under 10.4.7 (I think it was 10.4.7, basically it worked before a power outage caused a restart which updated the machine, then I updated again from 10.4.8 to 10.4.10 but the problem persisted)

Try binding with insecure ldap to see if that works.

Nick
najones
 
Posts: 1
Joined: 05. July 2007 17:14

Re: openldap ssl/ldaps problem

Postby spidee » 11. May 2009 10:42

Hi there same problem....this time on 1.7.1 connecting to and searching ldap:// works but
not ldaps:// any idea how to fix...running same code on stock sled / rhel boxes works
ok ?

Cheers !
spidee
 
Posts: 2
Joined: 11. May 2009 10:37

Re: openldap ssl/ldaps problem

Postby Etdashou » 26. August 2011 20:34

It would be so nice to have a solution to this issue.

I think that we need to compile OpenLDAP 2.x.x with SSL support, but I have absolutly not idea how to do this with XAMPP.
Etdashou
 
Posts: 24
Joined: 01. April 2008 20:20


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests