Page 1 of 1

CGI files are downloaded, not executed.

PostPosted: 01. July 2006 02:20
by Picatta
OK, I just installed linux and xampp onto it, and all is well, except for the cgi scripts. I have the first line set to #!/opt/lampp/bin/perl, and I tried chmodding the directory to 777, 755, 700, 600, 001, and anything else I could think of. Every time is asked where to download it to, except 700 when it said that permission was denied. What am I doing wrong?

Also, when the script is downloaded, it is empty. Is this a problem with the perl installation?

I just tried downloading activeperl and installing it. Then I set the first line to reflect the location of teh activeperl interpreter, and it still doesn't work. I REALLY need help.

Re: CGI files are downloaded, not executed.

PostPosted: 01. July 2006 16:59
by Dave_L
Picatta wrote:chmodding the directory.

Are the individual scripts executable, e.g. 755?

Are the scripts in the cgi-bin subdirectory? Or are the file extensions .cgi?

PostPosted: 01. July 2006 17:59
by Picatta
I tried chmodding both the directory and the file to 755. I also tried 700 and 777 and such, as in my post.

They (the cgi scripts) are in the cgi-bin/ directory, and have file extentions of .cgi.

OK, I just looked at my error logs, and I found this whenever I execute the script:

Can't find string terminator "EOF" anywhere before EOF at /opt/lampp/cgi-bin/nph-proxy.cgi line 8463.

This software is cgi-proxy, btw, so its no syntax error. The same script runs in windows version of xampp with active perl.