pbs with config.footer/header.inc.php: require(not existing)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

pbs with config.footer/header.inc.php: require(not existing)

Postby Pec » 27. May 2006 02:04

Hello, thanks for the super dev kit etc. :)

I've just installed lampp 1.5.2 on a Ubuntu 5.10.
Everything is launched, I access the main page on my localhost stuff, good.
On the status page evrything is green except the last two.
I execute the "security" command and the security page is beautifully green, nice.

I upload some html/php/css stuff to /lampp/htdocs/ and my favorite browser display my fantastic html/php fantasy. A few mysql commands in a script works fine.

BUT, when a try to access the phpmyadmin page i got a
Warning: require(./config.header.inc.php) [function.require]: failed to open stream: Permission non accordée in /opt/lampp/phpmyadmin/libraries/header_custom.inc.php on line 10

Fatal error: require() [function.require]: Failed opening required './config.header.inc.php' (include_path='.:/opt/lampp/lib/php') in /opt/lampp/phpmyadmin/libraries/header_custom.inc.php on line 10


So I open the "header_custom.inc.php" and find :
/* $Id: header_custom.inc.php,v 2.2 2005/11/25 08:58:11 nijel Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:

// This file includes all custom headers if they exist.

// Include site header

if (file_exists('./config.header.inc.php')) {



As it doesn't seem to be critical à quote the "require etc." and now i get the top of the page plus :
Warning: require(./config.footer.inc.php) [function.require]: failed to open stream: Permission non accordée in /opt/lampp/phpmyadmin/libraries/footer_custom.inc.php on line 10

Fatal error: require() [functi . . . .etc.

Same quotation, and finally, the proper phpmyadmin page, wich works well now.

I quite solve my problem, but I don't get it. The php manual says :
Note: Prior to PHP 4.0.2, the following applies: require() will always attempt to read the target file, even if the line it's on never executes. The conditional statement won't affect require(). However, if the line on which the require() occurs is not executed, neither will any of the code in the target file be executed. Similarly, looping structures do not affect the behaviour of require(). Although the code contained in the target file is still subject to the loop, the require() itself happens only once.

What could explain it, but in php 5.1.2 ? Isn't latter than 4.0.2 ? I have no clue.
And it seems to work well for anybody else so . . .
Posts: 1
Joined: 27. May 2006 01:45

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests